Opened 12 years ago

Closed 12 years ago

#3474 closed defect (fixed)

LURE: Messages sometimes refer to the wrong object

Reported by: eriktorbjorn Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: script Cc:
Game: Lure of the Temptress

Description

Latest ScummVM SVN snapshot
Lure of the Temptress, English version

Sometimes, when interacting with an object, the game prints a message that refers to the wrong object, or no object at all. For instance, if I try to pick up the barrel early in the game, I often get "The is far too heavy!" and sometimes when I've tried to pick up the sack I've gotten "The Cell door is far too heavy!"

I don't know about the empty string (the most common glitch?) but I did notice something interesting regarding the sack/cell door one.

As soon as the command is issued, the engine calls setField(ACTIVE_HOTSPOT_ID, ...) to, I guess, make the sack the active hotspot. But sometimes something causes setField(ACTIVE_HOTSPOT_ID, ...) to be called again in the time it takes for the protagonist to actually do the command. For instance, it can take a while for him to walk to the correct spot.

Dreammaster suggested that it may be some non-player character, e.g. the Skorl, triggering the change of hotspot.

Ticket imported from: #1842225. Ticket imported from: bugs/3474.

Change History (3)

comment:1 by sev-, 12 years ago

Would be nice to fix before the release.

comment:2 by dreammaster, 12 years ago

Resolution: fixed
Status: newclosed

comment:3 by dreammaster, 12 years ago

I realised when committing the code that the ACTIVE_HOTSPOT_ID value is used to get the current active hotspot when displaying a message - this may be the cause of the crashes in several of the other bug reports.

Note: See TracTickets for help on using tickets.