Opened 12 years ago

Closed 12 years ago

Last modified 12 months ago

#3475 closed defect (fixed)

INDY3 FM-TOWNS: Modified version does not start

Reported by: SF/zoppologo Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

I'm using the last scummvm svn (2007-11-30) under windows vista, but the problem is there since one of the first 0.11 builds:

i'm trying to play a modified version of INDY3 FM-TOWNS (translated from english into italian by a patch). ScummVM can't run it, it says 'Tryin to start game..." and it stops (i have to force scummvm to close).

The 0.10 version runs it fine.

Ticket imported from: #1842260. Ticket imported from: bugs/3475.

Change History (18)

comment:1 by SF/zoppologo, 12 years ago

Summary: INDY3 FM-TOWNS - modified version does not startINDY3 FM-TOWNS: modified version does not start

comment:2 by SF/zoppologo, 12 years ago

Summary: INDY3 FM-TOWNS: modified version does not startINDY3 FM-TOWNS: Modified version does not start

comment:3 by SF/glorifindel, 12 years ago

Hi, I'm the author of this patch (that it's still in work-in-progress status, but it's near its conclusion), I've used ScummTR (www.lucasforums.com/showthread.php?t=118680) to make it and it has always worked with 0.10 version of ScummVM

comment:4 by SF/glorifindel, 12 years ago

More recent patch version: http://www.mediafire.com/?4s23je9q3vk (90kb)

comment:5 by fingolfin, 12 years ago

OK, so we may have to improve the auto detector. Can you run it with -d1 and tell us the full output? I.e.

./scummvm -d1 TARGETNAME

comment:6 by SF/zoppologo, 12 years ago

if i run it with scummvm -d1 indy3
it just says:

Debuglevel (from command line): 1
Output sample rate: 22050 Hz
Looking for indy3
Trying to start game 'Indiana Jones And The Last Crusade'

and then stops

comment:7 by fingolfin, 12 years ago

Have you tried manually setting the platform to "fmtowns" (via. the "Edit game" dialog) ?

comment:8 by SF/glorifindel, 12 years ago

I've got the same result of zoppologo, and game platform is set to FM-TOWNS

comment:9 by SF/zoppologo, 12 years ago

the same happens with a french patch

comment:10 by fingolfin, 12 years ago

Odd. So, where can i get those patches? Preferably in a format which I can apply on my Mac, I don't have a Windows machine so I have a hard time running .exe files. Unless they are supported by DOSBox, that is...

comment:11 by SF/glorifindel, 12 years ago

I've made several b-diff files (binary diff files), one for each LFL, I hope you manage to update the game in your OS...
00.bdf = differences between original 00.LFL and patched 00.LFL
etc

comment:12 by SF/glorifindel, 12 years ago

Link to archive of BDF:
http://www.mediafire.com/?asrlsrpzaad
(74 kb, ZIP)

I've use this DOS tool:
www.programmersheaven.com/download/3103/download.aspx

comment:13 by fingolfin, 12 years ago

Priority: normallow

comment:14 by fingolfin, 12 years ago

I'll try to look into this during the weekend.

comment:15 by fingolfin, 12 years ago

For the future, I recommend you use e.g. bsdiff (http://www.daemonology.net/bsdiff/; there is also a Win32 version linked from there) for generating binary patches. The problem with "bdiff" is that there are a dozen or so programs under that name, each incompatible to the others. Your particular bdiff seems to be MS-DOS only. I'll try and see whether I can run it under DOSBox, though.

comment:16 by fingolfin, 12 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:17 by fingolfin, 12 years ago

Bug fixed! A *very* stupid mistake in the detector code which slipped through for far too long. Thanks for the report!

comment:18 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Indiana Jones 3
Note: See TracTickets for help on using tickets.