Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#998 closed defect (invalid)

MI2: Metronome ticking on JoJo's piano isn't heard.

Reported by: SF/quoth Owned by: SF/jamieson630
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Activating the metronome on the piano [Push/Use] in
the Scabb Island bar (where you get a job) does not
start the usual ticking sound effect.

Version: Win32 CVS - July 11/12

Ticket imported from: #770105. Ticket imported from: bugs/998.

Change History (12)

comment:1 by fingolfin, 16 years ago

Owner: set to SF/jamieson630
Summary: Metronome ticking on JoJo's piano isn't heard.MI2: Metronome ticking on JoJo's piano isn't heard.

comment:2 by SF/quoth, 16 years ago

Owner: SF/jamieson630 removed
Priority: normallow

comment:3 by SF/jamieson630, 16 years ago

Hardward platform?
Operating system?
Command line options or config options used?

comment:4 by SF/quoth, 16 years ago

P3 800MHz, GeForce 3 Ti500, Intel onboard SPU.
Windows XP SP1
Fullscreen, advmame3x.

I started it by opening the ScummVM GUI, adding the game
(E:\MONKEY2\), and going to 'Start'.
Also happens with the July 13th build. No other noticeable
sound issues. Need a savegame?

comment:5 by SF/jamieson630, 16 years ago

No, I don't think a savegame will be necessary. It sounds like
MI2 is probably running using a native Windows MIDI driver.
Since the SFX are Adlib-only, they don't play under a native
driver. This is not a bug.

Two options. First, run with the -eadlib command line option
to use Adlib music and SFX. Alternatively, run with the --
multi-midi command line option to enable simultaneous Adlib
and native driver support. (If you prefer the GUI to set things
up, you can set up Adlib use in the Options window, and you
can enable multi-midi after starting the game by pressing
Ctrl+D to bring up the debugger and enter "imuse_multimidi
on".

comment:6 by SF/jamieson630, 16 years ago

Owner: set to SF/jamieson630

comment:7 by SF/jamieson630, 16 years ago

Resolution: invalid
Status: newclosed

comment:8 by SF/jamieson630, 16 years ago

Since no response has been posted, I will assume that the
instructions that were given addressed the issue, and that
this bug report is invalid.

comment:9 by SF/quoth, 16 years ago

I also assumed this, and ended up trying the instructions but
to no avail. I seem to get other (digitised?) SFX fine, the
spitting and cleaning of the bartender for instance (is that
one, what else should/shouldn't I be able to hear?). Selecting
Adlib under the options doesn't save the option and always
goes back to "Default" (Which I thought was Adlib anyway?).
So I added this line under [monkey2]: "music_driver=adlib".
This didn't change anything for me in the game, So I then
proceeded to Ctrl+D and "imuse_multimidi on", this also didn't
change anything, the metronome was still not ticking. So I
cut that line from [monkey2] and put it under [scummvm],
same result- multimidi or not. Also the 'savepath' doesn't
save either.

comment:10 by SF/jamieson630, 16 years ago

At what point are you trying to activate the metronome?
When JoJo's playing the piano (and after you've hypnotized
him)? Or at the beginning of the game when Largo still runs
the place?

In the first scenario, I'm hearing the metronome just fine
using -ewindows and --multi-midi. In the second scenario,
you're not SUPPOSED to hear the metronome. This is true
even in the original LEC distro. In other words, the game isn't
even trying to play a sound effect at that point. The ONLY
time it tries to play a metronome sound effect is once JoJo's
at the piano (and after you've removed him).

comment:11 by SF/quoth, 16 years ago

At the very beginning just after Largo. I swore I heard the
metronome before I even knew about JoJo though, I was
stuck on Scabb Island for so long (the first time I played it).
At any rate if it didn't play in the original, which would be a
bug, why not fix it? Do you want to keep the original bugs
intact? Even one so inconsequential?

comment:12 by SF/jamieson630, 16 years ago

It is NOT a bug, and it is NOT inconsequential to change.
Cueing a sound effect that doesn't play in the original game
requires modifications to the game scripts, i.e. the game's
data files -- and since people don't run MI2 with modified
data files, that would mean hard-coding scripts into
ScummVM, which we will not do. The only things we improve
upon over the original distros are things we can do without
tampering with the original data files (such as the various
2x/3x graphics scalers). A very good example of this is the
simultaneous Adlib/native MIDI driver support in ScummVM.
The original distros did not allow you to hear the Adlib sound
effects *at all* if you chose to play GM/MT32 music.

I think that about answers the question. It's not in the
original, it's not a bug that's not in the original, and it won't
be in ScummVM. Enjoy the metronome once you've chartered
a ship and returned to Scabb Island later.

Note: See TracTickets for help on using tickets.