Opened 17 years ago

Closed 17 years ago

#727 closed defect (worksforme)

M1VGA-CD missing some audio tracks

Reported by: SF/gabumon79 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

when playing english monkey island 1 vga/cd version,
some of the audio tracks aren't played. it doesn't matter
if you let them play from cd or run them as ogg or mp3
files, the game misses always the same audio tracks.
these include the scumm-bar music, meele island
music, forest music, the one that should play right after
guybrush walks outta the screen in the first scene,
the "chapter 1" screen (which has the effect that this
screen one blinks up for about 200ms), and presumably
more.
ScummVM 0.3.0b release binary zip for windows
Built on Dec 6 2002 19:31:17
daily build (1227K exe file, last update: March 26, 2003,
5:08 pm) shows the same behavior.

Ticket imported from: #711209. Ticket imported from: bugs/727.

Change History (11)

comment:1 by SF/gabumon79, 17 years ago

Summary: missing some audio tracksM1VGA-CD missing some audio tracks

comment:2 by eriktorbjorn, 17 years ago

That's strange, it works flawlessly for me. At least with
Ogg Vorbis files. My only suggestion would be to turn on
debugging messages to see if they give any hints.

comment:3 by SF/gabumon79, 17 years ago

here is an excerpt from the debugging messages (level 5),
from the daily built mentioned above, when he shows the
chapter screen

loadResource(Sound,108)
;-----------exiting the first screen-----------
Loading room 96
loadResource(Room,96)
loadResource(Sound,104)
playSound #104 (room 96)
File track6.mp3 not found
File track6.ogg not found
Track 6 not available in compressed format
;---------entering the dock-----------
Loading room 33

so he complains that he can't find required audio files. but
they are DEFINITIVELY there, with the right filename
I tried everything. with/without read only flag, constant or
variable bitrate, different encoders, nuttin works
by the way, i get the same message when he should play
them from cd. why should he complain about missing files
when he should play cd tracks....?

comment:4 by eriktorbjorn, 17 years ago

> why should he complain about missing files when he should play
> cd tracks....?

It always checks for MP3 and OGG files first, even if the CD
is in the drive.

Are you sure your files are called track6.mp3 or track6.ogg,
and not track06.mp3 and track06.ogg or something like that?
I'm asking because all of the tracks you mention not hearing
are numbered below 10 while the intro music is track 17.

Apart from that, it's a bloody stupid question, but I've
found it often pays to eliminate the simple but stupid
possibilities first. :-)

comment:5 by SF/gabumon79, 17 years ago

> I've
> found it often pays to eliminate the simple but stupid
> possibilities first. :-)

*gg* exactly my thoughts
but yes, the files are named correctly.

comment:6 by eriktorbjorn, 17 years ago

Then I'm out of ideas. As far as I can see, the "File
track6.mp3 not found" message is only displayed if it fails
to find a file called "track6.mp3" in the same directory as
the rest of the data files. (Or in any subdirectory called
"video", "data", "resource" or "voices".)

Whether or not the file is a valid MP3 or OGG file shouldn't
matter at this stage.

And that still doesn't explain why playing the track from
the CD fails.

comment:7 by SF/gabumon79, 17 years ago

> And that still doesn't explain why playing the track from
the CD fails.

right. well, I just tested 'till sneaking into the forest. I'll go for
some more testing, using the cd. whatever, I have to rely on
scummvm for monkey1 cuz it crashes in plain dos on startup,
even with l2 and/or l1 cache disabled.

comment:8 by fingolfin, 17 years ago

If monkey2 crashes in normal DOS; I recommend DOSBOX http://dosbox.zophar.net/ (but use their latest CVS not he last release, it's much better).

Anyway, maybe we could insert some printf() statements at strategic places to track the problem down. Also I wonder if anybody else has similiar problems...

comment:9 by fingolfin, 17 years ago

I meant monkey1 not monkey2, of course.

comment:10 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:11 by fingolfin, 17 years ago

I asked several people to test this, nobody could reproduce the
problem. Closing

Note: See TracTickets for help on using tickets.