Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6647 closed defect (fixed)

WME: 5MA - main menu cat doesn't scream when clicked on

Reported by: misterhands Owned by: somaen
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

Using a recent win32 build (Kirben)
5 Magical Amulets

The cat in the menu does not scream when clicked on, only the cat_whiny sound is heard.
In the original, when clicking on it the 2 sounds (cat_whiny and cat_mad) sounds play
simultaneously.

Ticket imported from: bugs/6647.

Change History (7)

comment:1 by somaen, 5 years ago

Owner: set to somaen

comment:2 by SF/tobiatesan, 5 years ago

Can reproduce.
Looking into it.

Curiously BaseSound::play() for the relevant sound (sf\catmeow.wav) /is/ being called.

comment:3 by SF/tobiatesan, 5 years ago

Actually the problem is a little different: we play menu sounds with polyphony count == 1 instead of == many.

For example, try making the cat meow by passing over it with the mouse and then, very quick, go over a menu button.

The cat will stop meowing abruptly - you'll get something like "MEEO-click"

In the original executable, you have "Meeeee(click)ooooww".

For the same reason the "meeeow", which is triggered right after the screaming, steals the show.

comment:4 by SF/tobiatesan, 5 years ago

5MA ships with an older version of the WME interpreter (pre 1.8.6) which differs in this behaviour.

I think I got this fixed in https://github.com/scummvm/scummvm/pull/518

comment:5 by digitall, 5 years ago

When https://github.com/scummvm/scummvm/pull/518 is merged, this bug can be closed as fixed...

comment:6 by somaen, 5 years ago

Resolution: fixed
Status: newclosed

comment:7 by somaen, 5 years ago

I've commited the fixes from PR #518, minus the game flags-changes, closing this.

Note: See TracTickets for help on using tickets.