Opened 18 years ago

Closed 17 years ago

#518 closed defect (fixed)

DIG: End sequence

Reported by: SF/jsaathof Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

I played all the way thourgh The Dig and the end sequence stops playing after the spaceship dissapears. This is even worse than a T-shirt!

I use Scummvm 0.2.2 CVS built on Oct 26 2002 using a Debian Linux System. English takie version of The Dig.

Ticket imported from: #629424. Ticket imported from: bugs/518.

Attachments (2)

dig-credits-hack.diff (601 bytes ) - added by eriktorbjorn 18 years ago.
Hack to almost fix the end credits
dig.s37 (245.8 KB ) - added by eriktorbjorn 18 years ago.
Savegame near the end

Download all attachments as: .zip

Change History (13)

comment:1 by SF/ender, 18 years ago

This is due to our inability to display multiple textlines without keepText timing issues.

Needs to be addressed by a rewrite of description() and the main String code.

comment:2 by SF/khalek, 18 years ago

actually it doesn't stop it just doesn't display text. if you wait long enough you will see the lucasarts logo animation (with a spider?)

comment:3 by fingolfin, 18 years ago

I wonder if this got better since aquadran rewrote the description code?

comment:4 by eriktorbjorn, 18 years ago

I played through The Dig a few days ago. It displayed some (not all?) scrolling text messages, though never more than one at a time.

comment:5 by fingolfin, 18 years ago

Status: newpending

comment:6 by fingolfin, 18 years ago

This issue might be fixed due to various recent changes aquadran and me made... hence my question... Juriaan, would you please comment as to whether you can still reproduce the problem?

And if you can, attach a screenshot / a savegame, please.

comment:7 by fingolfin, 18 years ago

Status: pendingnew

comment:8 by fingolfin, 18 years ago

Sorry I obviously didn't read the problem description :-)

by eriktorbjorn, 18 years ago

Attachment: dig-credits-hack.diff added

Savegame near the end

comment:9 by eriktorbjorn, 18 years ago

Here's a savegame near the end. The reason the credits doesn't work seems to be that our implementation of o6_kernelSetFunctions(), case 16, only handles one string at a time. The end credits needs lots of them.

Or maybe it doesn't. I can get it to almost work (the text vanishes when it reaches the top instead of scrolling off) if I assume that I don't have to remember where the old string was and that it's enough to just clear the screen where the new string will appear. I'll attach my patch to demonstrate, but I don't know if this breaks anything else.

Another thing that doesn't work is that the game never ends since we don't implement shutDown(). What does this function have to do, other than _system->quit() anyway?

comment:10 by eriktorbjorn, 18 years ago

Can this be closed now?

comment:11 by SF/khalek, 18 years ago

it would be nice if the text could obey what I assume is a mask in the ft credits.

The text is supposed to come up behind the hill etc. Use shift W to get to the ft credits

comment:12 by fingolfin, 17 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.