Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#6592 closed defect (fixed)

SCUMM: ZAK - Read Ticket is too fast to read.

Reported by: SF/uka7 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

When reading a ticket in Zak (first room, beginning if the game), the first line ('departure/destination') appears too fast - it's impossible to read! Adjusting text speed (-/+) affects only the second line in that dialogue; the first is still too fast at any speed.
The issue is not present when running the game under DosBox (speed control affets both lines there).

Ticket imported from: bugs/6592.

Change History (9)

comment:1 by digitall, 6 years ago

Replicated with latest git master on Linux x86_64 using Zak V2/DOS/English.

As the submitter indicates, using the subtitle speed slider on CTRL-F5 -> Options affects the second line of "Read Ticket", but not the first which is very fast and hard to read the destination from...

comment:2 by digitall, 6 years ago

Summary: ZAK: errors in text speed control (some text is too fast)ZAK: First line of "Read Ticket" is too fast and not controlled by Subtitle Speed

comment:3 by SF/uka7, 5 years ago

Could anybody take a look and fix it please?
This bug has been reported earlier as well (#3233) - that ticket is closed now but the error still remains!

comment:4 by digitall, 5 years ago

https://sourceforge.net/p/scummvm/bugs/3233/

This bug does look like the same issue, but was closed by the submitter with no explanation, apart from "so it is not so sad" i.e. not a big deal facepalm

Anyway, so this was present since v0.9.1 at least.

Uka: You could try checking this with earlier versions of ScummVM and seeing if any of the versions before v0.9.1 work correctly... ie. gross bisection

Apart from that, we are open source so you could take a look yourself and see if you can see why this is occurring for the first, but not the second line...

comment:5 by digitall, 5 years ago

Summary: ZAK: First line of "Read Ticket" is too fast and not controlled by Subtitle SpeedSCUMM: ZAK - First line of "Read Ticket" is too fast and not controlled by Subtitle Speed

comment:6 by SF/uka7, 5 years ago

digitall, thanks for the suggestions but I am not a programmer and have no idea about coding :)

I have tried Windows versions 0.5.0 and 0.8.0 (0.4 and earlier did not work for me) - the bug is already there, and not only in Zak-EGA (enhanced) but in Zak-EGA (original) and Zak-FMTowns as well.

comment:7 by SF/uka7, 5 years ago

The issue is of course still present in version 1.7.0.

comment:8 by Kirben, 4 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Summary: SCUMM: ZAK - First line of "Read Ticket" is too fast and not controlled by Subtitle SpeedSCUMM: ZAK - Read Ticket is too fast to read.

comment:9 by Kirben, 4 years ago

The problem was due to the V2 version of Zak McKracken using a different message timing method for text, compared to later games, which was missing in ScummVM.

Fixed in ScummVM GiT, use the next daily snapshot of ScummVM GiT.

Note: See TracTickets for help on using tickets.