Opened 17 years ago

Closed 17 years ago

#654 closed defect

MI2: skeleton dance 'hangs'

Reported by: SF/sivu Owned by: SF/jamieson630
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 2

Description

monkey island 2 vga floppy english
scummvm version 0.3.0b
platform ipaq (pocketscumm)

the skeleton dance scene doesn't advance after guybrush says
his line after the first verse. skeletons just keep on dancing and
music keeps playing but the song doesn't go on.
if you skip the scene the game will go on but the paper is blank
because guybrush didn't start to write the words. Game is still
completeable but maze is quite hell without the 'map'

Ticket imported from: #659810. Ticket imported from: bugs/654.

Attachments (1)

monkey2.s07 (43.6 KB ) - added by fingolfin 17 years ago.
Just before the skeleton dance

Download all attachments as: .zip

Change History (25)

comment:1 by SF/sivu, 17 years ago

Summary: skeleton dance 'hangs'MI2: skeleton dance 'hangs'

comment:2 by fingolfin, 17 years ago

Works fine for me. What midi driver are you using?

comment:3 by SF/sivu, 17 years ago

i use the arisme's precompiled pocketscumm so the
mididriver is the default one.

comment:4 by fingolfin, 17 years ago

Owner: set to SF/arisme

comment:5 by fingolfin, 17 years ago

Assigning this to arisme as it seems to be PocketPC specific

comment:6 by fingolfin, 17 years ago

Arisme? Can you reproduce this? If yes, please tell us so, even if you can#t fix it right now...
If no, please close this as "Works for me".

In the meantime, Mikko, you might want to check if there is a newer build available and if yes, whether it still exhibits this problem.

comment:7 by SF/arisme, 17 years ago

A saved game would be more than welcome as this happens
near the end of the game :)

by fingolfin, 17 years ago

Attachment: monkey2.s07 added

Just before the skeleton dance

comment:8 by fingolfin, 17 years ago

Try this one.

comment:9 by fingolfin, 17 years ago

This one should do fine.

comment:10 by SF/arisme, 17 years ago

Well, it crashes (as soon as I load it, perhaps because I only
have the english CD version and the French floppy version) -
btw I had to modify the version detection to load it (Windows
version) on the latest CVS, I'll recheck on a Linux box to see
what happens.

Any other way to access this room with the proper objects if I
cannot load this saved game (on a desktop computer) ?

comment:11 by fingolfin, 17 years ago

Well, you only have to finish part I for this (getting rid of largo). I think this can be done in 30 mins or so, if you already know the solution (i.e. if you don't have to search for everything).

comment:12 by SF/arisme, 17 years ago

ok I'll recheck during the week with the latest CVS ... almost
sure it'll take more than 1 hour though :)

comment:13 by fingolfin, 17 years ago

OK, found a "shortcut" :-)
1) Enter the debugger and go to room 56
2) Take the oars
3) Use the debugger again to go to room 60
4) Plug the oars into the tree
5) Step up to trigger the dance sequence...

comment:14 by SF/arisme, 17 years ago

OK, now I've a good reason to add debugger support for the
next WinCE release :P

anyway I just tested it on Windows (CVS from last week) and
I have exactly this problem ... will update and recheck

comment:15 by SF/arisme, 17 years ago

Same problem with the latest build or a very old one - do I
need to have a specific object before loading this room ?

comment:16 by fingolfin, 17 years ago

Nothin additional needed. And I actually have the problem now, too, with the "debug" trick. OTOH no such problems with my save game. Weird. Maybe somebody else has an idea...

comment:17 by fingolfin, 17 years ago

Owner: changed from SF/arisme to eriktorbjorn

comment:18 by fingolfin, 17 years ago

Although this looks a lot like an iMuse problem ?! I wonder if this also occurs with old versions, e.g. say 1, 2, 3 months ago ? With 0.3.0b ? with 0.2 ?

comment:19 by fingolfin, 17 years ago

Owner: changed from eriktorbjorn to SF/jamieson630

comment:20 by eriktorbjorn, 17 years ago

When I tried the "debug" trick, the skeletons didn't even
start singing. However, when I played the game from the
start until I reached this scene, it worked flawlessly.

So did I just get lucky, or does skipping rooms that way
mess up the music enough to confuse the script? The latter
seems more likely to me, but...

comment:21 by fingolfin, 17 years ago

Erik, I concur with you. The only way to know for sure is of course to start a new game from scratch and play till that spot. It does work fine with my save games, but then, this doesn't gurantee it works with a newly started game.

So maybe this is just a glitch, or maybe it's a PocketPC specific problem after all; hence arisme will still have to play till that part.

comment:22 by SF/sivu, 17 years ago

i have a savegame which is taken just before the dance
scene but my pocket pc is in use in exhibition at the national
gallery of contemporary art so it is a bit hard to get the
savefile right now. :)
i remember i tried to get that dance scene working several
times (by using the save, not playing again from start) but it
always failed same way.

comment:23 by SF/arisme, 17 years ago

Rechecked with latest CVS tree, seems to work - crossing
fingers & closing :)

comment:24 by SF/arisme, 17 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.