Opened 7 years ago

Closed 7 years ago

#6099 closed defect (duplicate)

ZAK - Can't use anything in Shuttle Bug

Reported by: SF/quietust Owned by: bluegr
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Immediately after obtaining the Blue Crystal and giving it to Annie, I switched to Melissa and Leslie, put them in the shuttle, closed the door, then took off their helmets and tried to refill them from the oxygen tank. Trying to use the oxygen tank, however, just says "I can't reach it.", and the same thing happens when trying to interact with anything else inside the shuttle (controls, radio, boom box, glove compartment, etc.).

Observed with both Amiga and PC Enhanced versions.

Built from github commit ee818634abbf7c63c8b494f3b57f67b42cd3648a

Ticket imported from: #3543335. Ticket imported from: bugs/6099.

Attachments (1)

amiga_zak.s00 (8.4 KB) - added by SF/quietust 7 years ago.
Amiga autosave just after entering shuttne and closing door

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by SF/quietust

Attachment: amiga_zak.s00 added

Amiga autosave just after entering shuttne and closing door

comment:1 Changed 7 years ago by SF/quietust

The C64 version is also affected by this, but the FM Towns version is *not* affected. I haven't checked the PC Classic version, but it's likely that it's also affected.

comment:2 Changed 7 years ago by digitall

quietust: This sound like a duplicate of bug #3526089 "SCUMM: ZAK Can't get objects in the bus on Mars":
http://sourceforge.net/tracker/?func=detail&aid=3526089&group_id=37116&atid=418820

This seems to be a nasty intermittent / hard to replicate bug. Is it still happening for you?

comment:3 Changed 7 years ago by SF/quietust

I just rebuilt with latest sources (eba2ed99f8b8bf0d3aaf6a314ffbd9e196da8c8c) and it's still happening.

comment:4 Changed 7 years ago by SF/hardstyler777

I have exactly the same problem. I started again from the beginning of the game but I always get stuck in the shuttle and get the message: "I can't reach it". Were you able to solve the problem? What is the solution?

Can anyone provide a "minimalistic" scummvm savegame-file where not much of the game is played, but Melissa is able to pick things up in the shuttle?

comment:5 Changed 7 years ago by SF/hardstyler777

Ok, for completeness: I am using ScummVM 1.5.0 on a Mac OS X 10.7.2.
The save game from a windows machine, where Melissa can reach things in the shuttle results in a "I can't reach it" comment on the Mac! On both machines the SAME "Zak McKracken"-Version was used. I would say this is a proof that it is some bug in ScummVM. Please - can anyone help??

comment:6 Changed 7 years ago by SF/hardstyler777

For everyone who is looking for a fast solution:
Download an old version of scummvm:
E. g. v 1.1.1: http://scummvm.softonic.de/mac/download
and everything works fine.

comment:7 Changed 7 years ago by bluegr

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

comment:8 Changed 7 years ago by bluegr

As mentioned already, this is a duplicate of bug #3526089 "SCUMM: ZAK Can't get objects in the bus on Mars":
http://sourceforge.net/tracker/?func=detail&aid=3526089&group_id=37116&atid=418820

The bug should be fixed in the next daily version of ScummVM.

Closing as duplicate

Note: See TracTickets for help on using tickets.