Opened 7 years ago

Closed 7 years ago

#6093 closed defect (fixed)

DW: PSX version missing (many) music (cues)

Reported by: raziel- Owned by:
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

ScummVM 1.5.0pre (Jul 9 2012 08:17:50)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora AAC FreeType2

The background (midi) music is not loaded on the very first screen (bedroom) and stays also silent when entering and exploring the main hall.

The midi music is used right before the game starts in the "Act 1" curtain scene and stops abruptly after that.

Happens both with the PSX demo and full game.

The original (PSX) simply loops the bedroom music in the main hall (As the bedroom music is never loaded(?) and played(?) it's silent).

Discworld (CD/Sony PlayStation/English)
Discworld (CD Demo/Sony PlayStation/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3541541. Ticket imported from: bugs/6093.

Change History (8)

comment:1 Changed 7 years ago by SF/mthreepwood

I am unable to reproduce -- it works for me in the demo. Not to mention 0000.SEQ (the bedroom music) is the file I first tested the code on.

comment:2 Changed 7 years ago by SF/mthreepwood

Are you sure your volume is not at zero from testing the other bug?

comment:3 Changed 7 years ago by raziel-

Summary: DW: PSX version has no music in first sceneDW: PSX version missing (many) music (cues)

comment:4 Changed 7 years ago by raziel-

For the last question, yes, i have double checked and the volume is fine.

I had to change the title as this is not only affecting the first scene but the whole intro (checked with the original PSX).
i.e. in the scene with the drunk there are piano cues played that resembles the walking of the drunk, they are never heard in ScummVM.
As are the background violins.

As this does not only affect midi but adlib aswell and the whole game i hope you are ok with me changing the title?

comment:5 Changed 7 years ago by digitall

raziel_: bluegr has committed a number of fixes, which may have fixed this as a side effect.
Can you test the latest nightly build and see if this is still occuring?:
http://buildbot.scummvm.org/builds.html

comment:6 Changed 7 years ago by raziel-

Buildbot is not building AmigaOS4 (yet) :-)

Latest version has the same missing cues in whatever sound output i use (MIDI, ADLib, you name it)

comment:7 Changed 7 years ago by raziel-

Resolution: fixed
Status: newclosed

comment:8 Changed 7 years ago by raziel-

Fixed with one of the last commits

Tested with MT-32 and MU90R

Note: See TracTickets for help on using tickets.