Opened 7 years ago

Closed 7 years ago

#6083 closed defect (fixed)

SCUMM: MAZE Unknown Version (1999)

Reported by: SF/legoking831 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: detection Cc:
Game: Maze Madness

Description

There's an updated version of Maze Madness from 1999 that ScummVM fails to load. The error:
Starting "Freddi Fish and Luther's Maze Madness"
Your game version appears to be unknown. If this is blah blah...
SCUMM gameid "maze", file "maze.he0", MD5 "4522564b3c31aaf218b6a96826a549fd"
readMAXS(52) failed to read the MAXS data!

Not sure how to give the proper MAXS data, but if you need it, tell me.

Ticket imported from: #3540548. Ticket imported from: bugs/6083.

Attachments (2)

photo12.jpg (102.8 KB ) - added by digitall 7 years ago.
Photo of CD for reference
MazeMadness1999.txt (543 bytes ) - added by SF/legoking831 7 years ago.
Maze Madness 1999 MD5s

Download all attachments as: .zip

Change History (17)

comment:1 by digitall, 7 years ago

Summary: MAZE: Unknown revision from 1999SCUMM: MAZE Unknown Version (1999)

comment:2 by digitall, 7 years ago

legoking831: Thank you for this bug report. Please can you do the following:
1. Attach a file listing of the datafiles of this version along with file MD5sums to this bug, as a text file.
The output of a tool such as http://md5summer.org/ would be optimal.
This is to help identify the exact version and eliminate datafile corruption as the cause of this.

2. Please try recopying the datafiles from the original CD to see if the same result occurs i.e. again to help elimnate the
possibility of a bad media copying causing this difference.

3. Could you provide detail on the language version, publisher, packaging appearance and cover art appearance i.e. with reference to an Ebay/Amazon item for instance as this will help the developers locate a copy, as the usual sources lack detail:
http://www.mobygames.com/game/freddi-fish-luthers-maze-madness

comment:3 by SF/legoking831, 7 years ago

Disc is fine, absolutely nothing is corrupted about it. I made an image using ImgBurn with no read errors or anything, and I have successfully copied the files to my hard drive in the past.
Sadly enough, I can't find a picture on eBay that shows the disc, as that's the only thing I have. Should you come across it in the near future, here's a picture of the disc:
http://i43.servimg.com/u/f43/16/93/84/40/photo12.jpg
The disc has a copyright of 1996, 2001, but the game itself is has all the copyright and file modification dates at 1999. It's regular ol' US English. It's a copy my friend used to have, so I don't know how it was packaged.
The file folder is set up differently from most other HE games. Rather than the data files being on the root, they're in a folder called "Game", just like with the 1999 print of Freddi Fish 2. Only the autoplay related junk is on the root. Weird, huh? Anyway, the MD5s: http://www.speedyshare.com/4GCZ7/MazeMadness1999.txt

comment:4 by digitall, 7 years ago

legoking831: Please _ATTACH_ the text file to this bug.. (Attached File -> Add a file when logged in to sf.net) rather than using a weblocker service which requires a mandatory login, which is unacceptable.

comment:5 by digitall, 7 years ago

Attaching referenced photo as file.

lefoking831: If there is some underlying reason why you can't use sf.net attachments, then please use a public pastebin instead: http://pastebin.com/

by digitall, 7 years ago

Attachment: photo12.jpg added

Photo of CD for reference

by SF/legoking831, 7 years ago

Attachment: MazeMadness1999.txt added

Maze Madness 1999 MD5s

comment:6 by SF/legoking831, 7 years ago

I apologize, I don't know how to use SF well :(
Anyway, just added the file, let me know anything else you may need.

comment:7 by digitall, 7 years ago

legoking831: No worries. Just prefer attachments as external references like weblockers can get lost before someone gets round to looking at the bug.

I took a look at the SCUMM engine code and this looks like the game was detected as the wrong version as that message is emitted when the v6 readMAXS function is used (expected blockSize of 38), but the found value of 52 indicates that this is a HEv99 game.

Kirben has committed a detection entry for this version in commit 10ba526812daf504c086adf3057bdab643d3a3fe.

legoking831: Please remove your detection entry for the game and redetect with the next daily build, then report here if the game is detected correctly and whether this now runs correctly i.e. is running as a HEv99+ game:
http://buildbot.scummvm.org/builds.html

comment:8 by SF/legoking831, 7 years ago

It's detected correctly...still doesn't run. The error:
Assertion failed: _scummStackPos >= 1 && _scummStackPos <= ARRAYSIZE(_vmStack), file engines/scumm/script.cpp, line 716
Also, just a minor thing, but I'd recommend having ScummVM label it as Updated/English.

comment:9 by digitall, 7 years ago

legoking831: OK. Thanks for the update. It may take some time for a SCUMM engine developer to locate a copy and investigate why this is occurring. We will update this bug when a fix has been located. Please be patient and standby...

comment:10 by SF/legoking831, 7 years ago

No problem! It's not too urgent for me, as I also have the 1996 version (which does indeed work), but I'll keep my eyes open on eBay and let you know if I find one.

comment:11 by digitall, 7 years ago

Resolution: fixed
Status: newpending

comment:12 by digitall, 7 years ago

legoking831: Kirben has amended the HE version for this in commit 4f9b9ce3cc263b5e5ad9a223ca2a01f3b9ddaf39.
Please try removing your detection entry, then redetecting and running this game with the next daily build:
http://buildbot.scummvm.org/builds.html

If this works correctly, please confirm here, so we can close out this bug.

comment:13 by digitall, 7 years ago

Owner: set to Kirben

comment:14 by SF/legoking831, 7 years ago

Working beautifully, thanks!

comment:15 by Kirben, 7 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.