Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6082 closed defect (fixed)

TEENAGENT: string truncated after diving

Reported by: misterhands Owned by: digitall
Priority: normal Component: Engine: TeenAgent
Keywords: Cc:
Game: TeenAgent

Description

SCUMMVM 1.5git
Teenagent from GOG

After diving, Mark says : "weed is just like the flowers I gave mum on her last birthday."
It should read : "This seaweed is just like the flowers I gave mum on her last birthday."

Savegame uploaded. Use the mask + fins to dive.

I think I did encounter this at another place in the game but I can't remember where...

Ticket imported from: #3540542. Ticket imported from: bugs/6082.

Attachments (1)

teenagent.19 (35.2 KB) - added by misterhands 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by misterhands

Attachment: teenagent.19 added

comment:1 Changed 7 years ago by digitall

The dialog strings are held in the external datafile eseg...
I'm currently looking at this code so will try to work out a fix for this bug at the same time.

comment:2 Changed 7 years ago by digitall

Owner: set to digitall

comment:3 Changed 7 years ago by digitall

Found the cause of this problem i.e. there was a typo in the string offset. This was meant to be the string "It's nice down there", rather than the partial string output. Fixed in commit 31b00ac139ee7a4fa49b876a0560ad7282f47d59.

This will not be in release v1.5.0. Please use a daily master build. Closing as fixed.

comment:4 Changed 7 years ago by digitall

Resolution: fixed
Status: newclosed

comment:5 Changed 7 years ago by digitall

Oh based on the wrok I've done, I'd suspect the other place with a string issue is examining the car boot when empty... Please let me know and update this bug if you locate this.

comment:6 Changed 7 years ago by misterhands

Yep well done, that's the place !
Simply look at the empty boot and Mark says :
"nk I should push my luck."

Looks like I can't attach a savegame, tell me if you need it and I'll upload it somewhere else.

comment:7 Changed 7 years ago by digitall

Thanks. Fixed that in commit 8ac70ac94a6ecfcbb74c65aac730fa707ab6fa6e.

This will not be in release v1.5.0. Please use a daily master build.

Note: See TracTickets for help on using tickets.