Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#6084 closed defect (fixed)

TSAGE: Blue Force - Character stuck on animation loop

Reported by: (none) Owned by: dreammaster
Priority: high Component: Engine: TsAGE
Keywords: Cc:
Game: Blue Force

Description

When you try to close the gate in the island warehouse, the main character gets stuck in a loop of closing the gate animation. The gate remains open and you are unable to continue game any further. You can, how ever, access the game options by pressing assigned function key.

Ticket imported from: #3540893. Ticket imported from: bugs/6084.

Attachments (2)

BFORCE.md5 (862 bytes ) - added by SF/*anonymous 7 years ago.
Blue Force MD5sums
blueforce.011 (21.6 KB ) - added by SF/*anonymous 7 years ago.
save front of the warehouse

Download all attachments as: .zip

Change History (18)

comment:1 by (none), 7 years ago

Summary: Character stuck on animation loopBlue Force: Character stuck on animation loop

comment:2 by digitall, 7 years ago

toimint: Thank you for reporting this bug. However, in order to progress this, we will need some further information:
1. Please can you indicate your exact version of ScummVM you are testing with (This can be seen below the logo on the launcher i.e. v1.5.0XXX-git?
2. Please can you indicate your operating system?
3. Please can you attach a savegame just prior to this point, to this bug as an attachment. Please check that you can reliably replicate the bug from this.
4. Please attach a file listing of your Blue Force datafiles with file MD5sums as a text file to this bug. The output of a tool such as http://md5summer.org/ would be optimal. This is to identify your exact version and eliminate corrupt datafiles/esoteric variants.

comment:3 by digitall, 7 years ago

Summary: Blue Force: Character stuck on animation loopTSAGE: Blue Force - Character stuck on animation loop

by SF/*anonymous, 7 years ago

Attachment: BFORCE.md5 added

Blue Force MD5sums

by SF/*anonymous, 7 years ago

Attachment: blueforce.011 added

save front of the warehouse

comment:4 by (none), 7 years ago

The bug should occur, when you try to close the gate of the warehouse

The OS is Win XP, SP2
ScummVM version: 1.5.0git3365-ge4378d5

comment:5 by digitall, 7 years ago

tomint: Just checked your MD5sums. You have the Blue Force Floppy version, rather than the CD version.
This is confirmed by the savegame being blueforce-* rather than blueforce-cd-*

Renaming and loading this savegame into Blue Force CD, I can't replicate this issue (or see any memory issues) while running the latest Git master on Linux x86_32.

Since the engine is slightly different internally between the CD and Floppy versions, I suspect that it will require a TSAGE developer with the Floppy version to replicate and fix. This may take a little time. Please be patient and stand-by.

comment:6 by digitall, 7 years ago

Owner: set to Strangerke

comment:7 by digitall, 7 years ago

Strangerke: Do you have a copy of the Floppy version of Blue Force? If so, can you try replicating the bug with it from the given savegame? Also can you see if it match the file MD5sums given?
If not, would dreammaster have a copy?

comment:8 by dreammaster, 7 years ago

We had a user mention this bug previously, bug unfortunately then, as now, I couldn't replicate any problem. What might be useful is to start the action, and then immediately use Ctrl-F5 to open the GMM, and save the game. And then verify that the problem does occur. That way, we'll have the same conditions, exact same point you clicked on the gate, etc. and may be able to finally figure out under what conditions the loop is happening.

comment:9 by dreammaster, 7 years ago

Ah. It's the floppy version! That may explain why I've never been able to replicate the problem. Unfortunately, no, I don't have the floppy version to test with. :(

comment:10 by Strangerke, 7 years ago

Reproduced, working on it

comment:11 by sev-, 6 years ago

Priority: normalhigh

comment:12 by sev-, 6 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:13 by bluegr, 6 years ago

Here's some debugging info:

This is scene 900. The handling of the gate is done by Scene900::Gate::startAction() and _gateStatus is 2 when the door is about to be closed.

The sceneMode is then set to 9006 (close door), but after the gate animation finishes, signal() is never called, so it seems to keep repeating the same animation over and over. The door opening animation (9005) doesn't have this issue. Only the door closing one (9006).

comment:14 by Strangerke, 6 years ago

Yes, and it's not present in the CD version. I haven't been able to fix it yet.It may require a hack, in fact.

comment:15 by dreammaster, 6 years ago

Problem identified - the Blue Force floppy version had an animation frame set of 6 frames for opening the gate, whereas the scripts were expecting 8 frames. So the game presumes the animation is meant to be a repeating cyclical one, and keeps reseting the frame back to 1, and thus never reaching the end of the sequence.

To avoid any hacks in the core, I've added a workaround to the scene itself to kick in when the animation has started and force the 'end frame' down to 6 for the floppy version.

comment:16 by dreammaster, 6 years ago

Owner: changed from Strangerke to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.