Opened 17 years ago

Closed 16 years ago

#603 closed defect (fixed)

SAM: Sam talks forever inside BOTs diner

Reported by: SF/tzuyd Owned by: eriktorbjorn
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

ScummVM 0.2.82 CVS
Built on Nov 30 2002 15:05:15

English floppy version.

Running on WinXP (win32 daily snapshot build)

Inside the diner on top of the ball of twine : When Sam
attached the power cords to the telescope - he
says 'now we can control the diner's rotation using this
telescope' and keeps talking forever. Save game
attached, has happenned for as long as I've known
about ScummVM =]

I hadn't reported this earlier in the hope that someone
else had spotted it by now :) but with the impending
0.3.0 release and all...

Ticket imported from: #645976. Ticket imported from: bugs/603.

Attachments (5)

samnmax.s09 (56.4 KB ) - added by SF/tzuyd 17 years ago.
Saved game in slot 9 inside the diner
samnmax.s02 (48.3 KB ) - added by SF/khalek 17 years ago.
VR machine
samnmax.s03 (72.1 KB ) - added by SF/khalek 17 years ago.
stage room in bumpusville
samnmax.s04 (71.9 KB ) - added by SF/khalek 17 years ago.
bedroom in bumpusville
samnmax.s05 (147.2 KB ) - added by SF/khalek 17 years ago.
highway minigame

Download all attachments as: .zip

Change History (32)

by SF/tzuyd, 17 years ago

Attachment: samnmax.s09 added

Saved game in slot 9 inside the diner

comment:1 by SF/jamieson630, 17 years ago

Yeah, I encountered this too, first time I played through.
Seems to be a problem with the "zap-spark" sound going on
behind him as he says it. The logic to figure out when the
talking sound finishes is getting confused by the other sound
effect that loops forever.

I didn't notice it the last time I played through, so I thought it
was fixed.

If you save the game during the hangup and reload it from that
spot, it will continue normally. At least, that fixed it for me the
last time I encountered the problem. (Obviously this is just an
interim way around the problem.)

comment:2 by SF/tzuyd, 17 years ago

Well that doesn't fix it for me =[

But the aforementioned CVS build at least resumes the
zappy sfx when you reload, that didn't happen last time I
checked ;]

comment:3 by SF/kwyj, 17 years ago

I'd just like to add that the bug remains in the ScummVM
0.3.0b release, and that saving, then restoring, doesn't work
for me either.

And as for the daily build (ScummVM 0.3.1cvs, December
26, 2002), the game doesn't even load.
Detected game 'Sam & Max', version 6.4.2
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
WARNING: o6_miscOps: _saveSound=1!
Error(71:1:0x539): Too many nested scripts!

comment:4 by SF/lord_nightmare, 17 years ago

I've found no less than 5 places where this bug, which seems to be caused by looping sound effects never finishing,
occurs. (talkDelay never hits zero?)
1. BoT diner, hooking up the binoculars (recoverable, might not occur in CD version)
[see existing savestate, TAKE wires, use them on binoculars]
2. In the VR machine in bumpusville (unrecoverable)
[samnmax.s02; LOOK at the heart]
3. In the stage room in bumpusville (unrecoverable)
[samnmax.s03; WALK to the beam (which is pretty messed up due to transparency issues, see SF bug #65xxxx)]
4. In the bedroom in bumpusville (unrecoverable)
[samnmax.s04; TAKE the toupee]
5. In the Highway minigame (unrecoverable, only occurs when you run out of time by CRASHING as opposed to just
letting your time run out)
[samnmax.s05; just sit there and do nothing and you'll die, eventually. note that hitting esc does NOT exit the minigame
due to a different bug]

I hope these examples help us get rid of this annoying bug once and for all.
Lord Nightmare AKA Jonathan Gevaryahu

by SF/khalek, 17 years ago

Attachment: samnmax.s02 added

VR machine

by SF/khalek, 17 years ago

Attachment: samnmax.s03 added

stage room in bumpusville

by SF/khalek, 17 years ago

Attachment: samnmax.s04 added

bedroom in bumpusville

by SF/khalek, 17 years ago

Attachment: samnmax.s05 added

highway minigame

comment:5 by SF/lord_nightmare, 17 years ago

Oops. #65xxxx should have been #651077 :P

Lord Nightmare AKA Jonathan Gevaryahu

comment:6 by fingolfin, 16 years ago

Priority: normalhigh

comment:7 by fingolfin, 16 years ago

Still seems to happen (closed bug #728446 which is a duplicate of this
one).

Seems to be a pretty nasty problem, raising priority.

comment:8 by SF/tzuyd, 16 years ago

This bug appears to be squashed.

comment:9 by fingolfin, 16 years ago

Hm, are you sure? That other bug was only made 2 weeks ago.. of
course the bug might have been fixed as a side effect of some other
change since then, but still..

comment:10 by SF/tzuyd, 16 years ago

Well, it worked for -me-, I should say ;] Using the floppy
version of Sam'n'Max. All those other points Lord Nightmare
made may still be problematic, I havn't reached those spots
yet.

comment:11 by SF/jamieson630, 16 years ago

The floppy version doesn't have the talkie voice pack, does it?
In which case, this bug would not manifest itself. It only
causes a problem with digital voice audio superimposed on
digital audio sound effects. This bug should apply to the CD-
ROM version of the game only.

comment:12 by SF/tzuyd, 16 years ago

Well, the ball of twine diner thing happenned. It was
happenning for awhile. I've always been playing floppy
version. It's not happenning anymore. Not for me.

I wouldn't've made the original post if it wasn't happenning ;]
What else can I say ;]

comment:13 by SF/pepijnvdgeer, 16 years ago

the bugs gone in the cdrom version too.
(I'm using Scummvm 0.4.1cvs and Linux RH 8)

comment:14 by (none), 16 years ago

I tried with 06 May 2003 latest CVS. The problem hasn't gone
in with my floppy version of Samnmax. I reported a
workaround in a dupe of this bug, just save and reload for
three times. Still, the problem remains the same.
Using the italian version of the game.
I also previusly reported problems with default audio
settings that forced me to switch manually to Adlib (or
ScummVM passes always in debug mode once started).

comment:15 by fingolfin, 16 years ago

When you say you use latest CVS, do you mean you compiled the trunk
yourself (and thus are using version 0.4.1cvs), or are you using the
branch (version 0.4.0pre) which doesn't have the fix?

comment:16 by (none), 16 years ago

Ok, you're right, I downloaded "# Win32 Daily Snapshot
(1130K exe file, last update: May 6, 2003, 7:14 pm)". Sorry,
I didn't see there was the possibility of download and
compile cvs. I thought that the "Daily" word stood for
"latest version available". I'll try again in the future,
when I'll have the time to install a cvs client. Thank you
for your patience.

comment:17 by fingolfin, 16 years ago

No problem, lordhawk! I am glad you took the time to report.

Anyway, if you wait till monday (if all works out smooth), the dailys will
have the change, and you can try again. Or maybe somebody can send
you a build.

comment:18 by (none), 16 years ago

Mmmmhh... using 0.4.1cvs (14 May Daily Snapshot) and still
I've the same problem... this bug hasn't got fixed for me.

comment:19 by fingolfin, 16 years ago

Lordhawk, is that with an old savegame? Does it also happen if you
start a new game from scratch?

comment:20 by SF/mnbv, 16 years ago

I've had this same bug under linux with the 0.4.1cvs build.
I also noticed that saving, and reloading managed to get me
past this although I had to do this a couple of times.

I also had an instance in bumpusville where this happened.
It happened the first time I broke the security beam.

Unfortunatly I don't have either of the save files any more :(

comment:21 by SF/lord_nightmare, 16 years ago

be aware that the savefiles which khalek kindly uploaded for
me a while back are probably no longer compatible with the
latest scummvm. However, each and every one of those freezes
still happens. Jamieson360 submitted an additional bug
report on the one which happens after the highway subgame,
since unlike the rest of them, that one seems to also happen
in the CD version.
I managed to recover from a few of the freezes which I
previously listed as unrecoverable, also.

Lord Nightmare

comment:22 by SF/chrilith, 16 years ago

I think this is a problem with the sound mixer engine.
I have the same problem with DOTT on PalmOS and i fix
this by removing the monster.sou file. This seems to
work also with the Win32 lastest snapshot

comment:23 by eriktorbjorn, 16 years ago

If the floppy version is anything like the CD version,
there's a "wait for message" opcode right after Sam starts
talking. Could it be this that's hanging? I never quite
understood how VAR_HAVE_MSG / _haveMsg / _talkDelay thing works.

comment:24 by eriktorbjorn, 16 years ago

I think this is fixed in CVS now. Somebody please verify.

comment:25 by SF/segra, 16 years ago

tested with floppy and cd version on latest cvs ;), neither
get stuck at that point

comment:26 by eriktorbjorn, 16 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:27 by eriktorbjorn, 16 years ago

Cool. It's about time we closed this one. Let's hope I
didn't introduce any new bugs in the process.

Note: See TracTickets for help on using tickets.