Opened 17 years ago

Closed 16 years ago

Last modified 16 years ago

#602 closed defect (invalid)

MI1: bug when becoming invisible

Reported by: SF/sir_kill_a_lot Owned by:
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

When Guybrush becomes invisible on the ghostship the
visible Guybrush and the unvisible doesn't match
eachother. I made a screenshot of the english version
using scummvm, and another using the german version
with scummvm (in the german version that looks right,
so I don't know if it's a bug of MI1VGA-English or
ScummVM! Btw, the german MI1VGA [from Monkey
Madness CD] has *.lec resource files and no grapical
user interface with icons in the inventory as the english
version has so they are a little different).

screenshots and savegame attached
ScummVM 0.2.82 CVS Built on Nov 28 2002 on Win32

Ticket imported from: #645727. Ticket imported from: bugs/602.

Attachments (3)

monkey.s07 (42.5 KB ) - added by SF/sir_kill_a_lot 17 years ago.
savegame
mi1vga-eng-invisible-scummvm.png (31.9 KB ) - added by SF/sir_kill_a_lot 17 years ago.
screenshot of english version
mi1vga-ger-invisible-scummvm.png (31.9 KB ) - added by SF/sir_kill_a_lot 17 years ago.
screenshot of german version

Download all attachments as: .zip

Change History (14)

by SF/sir_kill_a_lot, 17 years ago

Attachment: monkey.s07 added

savegame

by SF/sir_kill_a_lot, 17 years ago

screenshot of english version

by SF/sir_kill_a_lot, 17 years ago

screenshot of german version

comment:1 by fingolfin, 17 years ago

Priority: normallow

comment:2 by SF/andrej4000, 17 years ago

There is no german Monkey Madness CD.
I think you just have another compilation with MIVGA
german and Monkey2 german.

The Monkey Madness Edition is only in english.

comment:3 by SF/sir_kill_a_lot, 17 years ago

Okay, it's actually called "Monkey Island Special". It
contains MI1 (german), MI2 (german) and MI3-Demo
(english). But the (german) manual on the CD says "Monkey
Island Madness" so I thought this is the same Monkey
Madness as the english one.

comment:4 by SF/andrej4000, 17 years ago

I think they just added the manual there...

On the original Madness CD no copy protection is asked in
Monkey1 (because it isn't the same as MIVGA) and in
Monkey2 (just a special interpreter to avoid the questions)

comment:5 by fingolfin, 17 years ago

Summary: MI1VGA: bug when becoming invisibleMI1: bug when becoming invisible

comment:6 by fingolfin, 17 years ago

I can reproduce this bug, but not in monkeyvga (works fine there), but rather
in normal "monkey".

comment:7 by SF/trinity78, 17 years ago

this is still present in the current cvs/version 0.40.
tested with Monkey Island CD-Version german (with gui and
item-icons)

comment:8 by fingolfin, 16 years ago

Still occurs in latest CVS with my english/macintosh MI

comment:9 by SF/logicdeluxe, 16 years ago

I can reproduce this bug even with the original interpreter.
Seems to be a bug with some or all enhanced CD versions.
This does not happen with monkeyvga. I tested with the
German and English disk version and with the multi language
CD. Also the violin ghost is slightly brither in that
version (as seen in the screen shot) which is normal in that
version.
Either ScummVM could hack the script in that version or
leave it alone, as it is really no problem.

comment:10 by fingolfin, 16 years ago

Ahh! That explains why I just wasn't able to find any explanation
for the problem - we actually doing everything right :-). Thanks
for checking the original, logicdelux / Marek, that was very
helpful.

comment:11 by fingolfin, 16 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.