Opened 18 years ago

Closed 18 years ago

#604 closed defect (fixed)

INDY4 INTRO: white indy in room 3?

Reported by: SF/cruchot Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

During the intro, when Indy falls down in the cellar (after being scared by a cat), Indy becomes white (check screenshots) until he leaves the room.

I know usually I click through the intro, but maybe it's just because the costume is missing?

I'm using the latest CVS build (ScummVM 0.2.82 CVS), and I'm playing Indy4 version 5.5.5.0 french on Suse linux 8.0

Ticket imported from: #646184. Ticket imported from: bugs/604.

Attachments (1)

atlantis1.jpg (58.1 KB ) - added by SF/cruchot 18 years ago.

Download all attachments as: .zip

Change History (5)

by SF/cruchot, 18 years ago

Attachment: atlantis1.jpg added

comment:1 by eriktorbjorn, 18 years ago

This is likely to be a very recent regression, because I can't reproduce it with the latest Windows snapshot, which was compiled yesterday. I see what may be causing it, though:

There's a line in setPaletteFromPtr() in gfx.cpp that reads

if ((_features & GID_MONKEY_VGA) || (_features & GF_AFTER_V7) || (i <= 15 || r < 252 || g < 252 || b < 252) {

The first part should read (_gameId == GID_MONKEY_VGA) instead. Whoops!

comment:2 by fingolfin, 18 years ago

Oops, I fixed setPaletteFromPtr(). But even before I did that I couldn't reproduce this bug... hm. Ludovic, does it still happen with latest CVS?

comment:3 by SF/cruchot, 18 years ago

No, the bug's fixed, thank you!

comment:4 by fingolfin, 18 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.