Opened 7 years ago

Closed 7 years ago

Last modified 12 months ago

#6028 closed defect (fixed)

GUI: Button press graphics not working after subdialog close

Reported by: lordhoto Owned by:
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

Linux/amd64
g++ 4.7.0
commit: b96143c1802b619553e476ad7a5a1eedeea0c768
theme: scummmodern

The special pressed button graphics is not always displaying. An easy way to reproduce this is start ScummVM, click on the "Options..." button, close the options dialog and click on the "Options..." button again and hold the mouse key down to avoid the dialog from opening. The button only appears pressed the first time when you click on "Options..." directly after starting ScummVM for me. After closing the dialog I was not able to get the "Options..." button from getting the pressed look.

As far as I can tell the "_lastTime" member of ButtonWidget of the button for "Options..." does not get properly set to 0 again when a the options dialog opens. This might be related, since ButtonWidget::handleTickle disables the pressed state after some time, when "_lastTime" is not 0.

Ticket imported from: #3523325. Ticket imported from: bugs/6028.

Change History (4)

comment:1 by digitall, 7 years ago

lordhoto: Was this fixed by the recent commit? i.e. 97065c95e654f36070b8f12f20b3bff1752b5e0c

comment:2 by digitall, 7 years ago

Resolution: fixed
Status: newclosed

comment:3 by digitall, 7 years ago

Just tested. This seems fixed to me, and have checked with Lordhoto. Closing.

comment:4 by digitall, 12 months ago

Component: GUI
Note: See TracTickets for help on using tickets.