Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6014 closed defect (fixed)

SIMON1DOS French: subtitle glitch in introduction

Reported by: misterhands Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

SCUMMVM 1.4.1, Simon1 CD/DOS/French

Not really a bug, more a minor glitch, but I thought I'd report it anyway.
In the intro during the goblins_cooking_poor_simon scene, when the goblin
pushes Simon in the pot and says "down food", the French subtitle displayed is :
"Plus bas,

ourriture."
Notice the added blank line in the middle, and the missing first letter "n" in the word nourriture.
Interestingly, the game crashes at that very spot in dosbox, which makes scummVM even more essential I may add.
So it looks like the added blank line and missing letter are a byproduct of a scummVM hack/fix to address the crash.
See bug ID: 770838, it seems to be related.

Anyway, a quick look in SIMON.GME reveals that the missing "n" is there so I assume it should be fixable without to much sweat.
As for the added line, I can live with it, but I'll let you C++ maestros decide if something can or should be done about it.

Thanks!

Ticket imported from: #3512776. Ticket imported from: bugs/6014.

Change History (12)

comment:1 by digitall, 8 years ago

Owner: set to Kirben

comment:2 by digitall, 8 years ago

Hmm... Looks like a regression since the fix in bug #770838 "SIMON1DOS: Fatal crashes with French version":
https://sourceforge.net/tracker/?func=detail&aid=770838&group_id=37116&atid=418820

Since this was 2003-07-14 03:18, that means the fix was in 0.4.0..

misterhands: Could you try this with some older versions i.e. v1.4.0, v1.3.1, v1.2.1, v1.1.1, v1.0.0 etc. to try to see if this was a recent regression? Could you also be clear what platform you are using i.e. Win32, Linux, MacOSX?

comment:3 by misterhands, 8 years ago

Ok I've tried a bunch of older versions from 1.4 to 0.4 and basically there is no difference,
other than showcasing the evolution of scummvm !
It looks like the missing letter and added line have been there since the fix in 2003.
I use win32.

comment:4 by digitall, 8 years ago

misterhands: Thanks for this update.
Looking at this, the correction for the crash with the Simon1DOS French version was added in commit
4ae380102a533a8a332e46a4daea2a273f3930a1

Fix for Bug [770838] SIMON1DOS: Fatal crashes with French version

Fix variable underflow for large subtitle strings with no
discernable whitespace. This fixes crashes for French subtitles
that do, in fact, have whitespace but perhaps not using the
same ASCII character that we scan for. Anyway, the text will
display, albeit with an extra blank line, and ScummVM no longer
blows up.

svn-id: r9009

This corrected some code in the function:
void SimonEngine::talk_with_text(uint num_1, uint num_2, const char *string_ptr,...

comment:5 by digitall, 8 years ago

This function no longer exists in that file or with that name.

However, I think the relevant code has been moved to engines/agos/string.cpp and is now within the function "void AGOSEngine::printScreenText(uint vgaSpriteId, uint color, const char *string, int16 x, int16 y, int16 width)"

Hopefully this should help the AGOS developers look at a possible fix for this issue...

comment:6 by lordhoto, 8 years ago

Summary: SIMON1DOS French : subtitle glitch in introductionSIMON1DOS French: subtitle glitch in introduction

comment:7 by digitall, 8 years ago

Hmm... commit e457a3f2513529930d16636155243dfc125035bd :
" Add workaround for bug #1538873 - SIMON1 (French): Text wrongly displayed.

svn-id: r42474"
may also be relevant to this...

comment:8 by Kirben, 8 years ago

Resolution: fixed
Status: newclosed

comment:9 by Kirben, 8 years ago

Fixed in ScummVM Git, use the next daily snapshot of ScummVM GiT.

The problem was due to the French version failing to update the width, for this particular string. I added a work around to set the correct width.

Please report any other locations you notice this problem, to this bug report, so they can be worked around too.

comment:10 by misterhands, 8 years ago

Sorry this is not fixed for me...
This is with the daily snapshot 1.5.0git2811-gb886bc0 (Apr 2 2012 11:00:30)

comment:11 by Kirben, 8 years ago

Fixed in ScummVM Git, use the current Windows snapshot of ScummVM GiT.

The string ids were different in the Floppy Disk and CD version, so I had to expand the bug fix.

comment:12 by misterhands, 8 years ago

It works ! thanks !

I did a play through of Simon 1 recently and I did not notice other occurrences of this bug.
I did however notice other bugs, I'll report them later.

Note: See TracTickets for help on using tickets.