Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5947 closed defect (invalid)

DIG: Engine about at IMUSE error "_outputSize: 8472"

Reported by: SF/herman2000 Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Version: ScummVM 1.5.0git2072-g29a063c (Jan 18 2012 10:17:27)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib FluidSynth Theora AAC
Details: After solving the door puzzle (where the door does not open unless you wire it to an open, electric conduit some time after reviving Brink), entering the thus-revealed room crashes the game about 8.6 seconds in; even switching to the PenUltimate does not change that, leading to the assumption it has to do with the music.
Game Language: English
Game Version: DOS
Platform: Win32; recent snapshot as compiled by "Kirben"

Ticket imported from: #3475599. Ticket imported from: bugs/5947.

Attachments (1)

dig.s01 (46.0 KB ) - added by SF/herman2000 8 years ago.
Savestate just before the opened door to the room

Download all attachments as: .zip

Change History (10)

by SF/herman2000, 8 years ago

Attachment: dig.s01 added

Savestate just before the opened door to the room

comment:1 by digitall, 8 years ago

Summary: Crash with "_outputSize: 8472"DIG: Engine about at IMUSE error "_outputSize: 8472"

comment:2 by digitall, 8 years ago

This error is called from within the function:
int32 BundleMgr::decompressSampleByIndex(int32 index, int32 offset, int32 size, byte **compFinal, int headerSize, bool headerOutside)
found in engines/scumm/imuse_digi/dimuse_bndmgr.cpp.
The specific error call is at line 296.

I can't replicate this with my version of "The Dig", Git master and the attached savegame..

comment:3 by digitall, 8 years ago

herman2000: Thanks for this bug report, but to progress this, we need to identify your specific version of The Dig and eliminate the possibility of corrupted datafiles.
Can you please attach MD5sums for your Dig datafiles to this bug as a textfile?
The output of a tool such as http://md5summer.org/ would be optimal.

comment:4 by eriktorbjorn, 8 years ago

I can't reproduce it either, and I'm not getting any Valgrind warnings. These are the MD5 sums for my sound files:

5491cdd68d792b4e3e335ecee80f9019 digmusic.bun
beb6d64ccf146f82a26a1ab65a4c4b13 digvoice.bun

comment:5 by SF/herman2000, 8 years ago

bf2698198e89f3f10150f771a998b4a9 *DIGMUSIC.BUN
51ac4af72f9f0401b3f82d43e428c286 *DIGVOICE.BUN

Guess something went wrong with those files on my part.

If it matters, ScummVM says the game's "The Dig v1.0".

comment:6 by digitall, 8 years ago

I get the same MD5sums as eriktorbjorn. Please confirm that you have not compressed these files with the scummvm-tools?
If not, then please try recopying them from the original media.

comment:7 by SF/herman2000, 8 years ago

Sorry for the delay in a response, been busy.

I re-checked the files and compared them to my files on my disc -- it appears there was some data transfer trouble when copying onto the hard drive.
Re-copying using my secondary disk drive did the trick and cleared the issue.

Sorry for the hassle.

comment:8 by digitall, 8 years ago

OK. Thank you for confirming this. Closing as invalid...

comment:9 by digitall, 8 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.