Opened 9 years ago

Closed 9 years ago

#5943 closed defect (fixed)

AGI: Predictive keyboard not working properly

Reported by: SF/stc2000 Owned by: wjp
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 1

Description

ScummVM 1.4.0 (Dic 5 2011) - Nokia N800 with OS2008. When running Space Quest and other AGI games (King Quest, etc.) the predictive on screen keyboard does not recognize verbs like TAKE, BUY, etc. The keyboard worked properly in previous ScummVM releases up to 1.2 and fully recognized the mentioned verbs. Thanks,

Ticket imported from: #3470080. Ticket imported from: bugs/5943.

Change History (7)

comment:1 by digitall, 9 years ago

Summary: MAEMO: AGI Predictive keyboard not working properlyAGI: Predictive keyboard not working properly

comment:2 by digitall, 9 years ago

Tested on Linux x86_32 with latest Git master and confirmed that take is not recognised, when pred.dic is copied to extras path to enable predictive input.

This is probably caused by 69c705a0199f2526f2df774e1b2ee5cddaa63f6c and dbd5ffaf34e690559380721e0f132b637b8fce33 which were the fixes for bug #3424066 ("LSL1 AGI: Password Glitch"): https://sourceforge.net/tracker/index.php?func=detail&aid=3424066&group_id=37116&atid=418820

Will bisect to confirm.

comment:3 by wjp, 9 years ago

Partially fixed in 41ba2433f57f064f3119b5b5c1247eadb32d5977, but, quoting the commit message:

Note that there are still issues with this input mode. If the binary search hits a prefix match before finding the full match, it won't recognize the full match. (Example: typing "buy" will show "buz" because it's aiming for "buzzard" without realizing "buy" exists.)

comment:4 by digitall, 9 years ago

wjp: Thanks for the partial fix. I was incorrect in suspecting this to be fairly recent. This regression was introduced by: commit 4b2f92b5e56a1fc273c8c8d2e69b747f938ea92f Author: Max Horn <max@quendi.de> Date: Thu Jan 6 21:11:24 2011 +0000

AGI: Rewrote predictive code matcher

The new code is simpler, avoids a potential buffer overrun (by avoiding to to use a buffer in the first place), and hopefully has slightly more sane matching properties.

svn-id: r55135

Hope this helps to compare matching behaviour...

comment:5 by wjp, 9 years ago

Should be fixed entirely now.

comment:6 by wjp, 9 years ago

Owner: set to wjp

comment:7 by wjp, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.