Opened 8 years ago

Closed 8 years ago

#5944 closed defect (invalid)

TOON: Game Freeze Talking To CareCrow

Reported by: SF/foleyjo Owned by: sylvaintv
Priority: normal Component: Engine: Toon
Keywords: Cc:
Game: Toonstruck

Description

Version GIT 6b8fb196-pre1.4.0
Problem :The game freezes during talking to the Scarecrow (CareCrow)..
Language: English
Version: CD
Platform: Caanoo

Ticket imported from: #3473747. Ticket imported from: bugs/5944.

Attachments (2)

toon.000 (25.1 KB ) - added by SF/foleyjo 8 years ago.
toons.md5 (1.4 KB ) - added by SF/foleyjo 8 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 by digitall, 8 years ago

foleyjo: Thank you for this bug report. Can you provide the following information to help progress this bug:
1. Can you confirm exactly when this occurs i.e. first sentence or a specific phrase while talking to the Carecrow?
2. Please can you test with the last few stable releases i.e. v1.4.0, v1.3.1 and v1.3.0 and confirm if this also exhibits the same bug i.e. this will confirm if this is a recent regression and if so, provide some idea when it was introduced?
3. Can you attach a savegame file just prior to talking to the Carecrow to allow easy replication/bug testing?
4. Can you replicate this issue on a desktop stable build i.e. v1.4.0 Win32/Linux/OSX ?
5. Can you attach a textfile to this bug listing your toonstruck game datafiles including file MD5sums (so we can eliminate corrupted game data)? The output of a tool such as http://md5summer.org would be optimal.

We can then look at progressing this bug. Thanks.

comment:2 by digitall, 8 years ago

Owner: set to sylvaintv

comment:3 by digitall, 8 years ago

Summary: Caanoo ToonStruck FreezeTOON: Game Freeze Talking To CareCrow (Caanoo)

comment:4 by digitall, 8 years ago

Owner: changed from sylvaintv to djwillis

comment:5 by digitall, 8 years ago

OH... I have just realised that we have not had Caanoo release builds since
v1.2.1, except for this pre-release build from DJWillis which this bug is against..:
http://blogs.distant-earth.com/wp/?p=355#more-355

DJWillis: Could you look at doing a newer build for at least v1.4.0 stable or will this get updated for v1.4.1?

by SF/foleyjo, 8 years ago

Attachment: toon.000 added

by SF/foleyjo, 8 years ago

Attachment: toons.md5 added

comment:6 by SF/foleyjo, 8 years ago

Hi

1-Seems random. Just during the opening speech of the Carecrow.
2-no sorry
3-I have attached the save from just before clicking on him
4-Replicated. Game froze and then closed to desktop
5- I have attached an MD5 file using the app you said. Is this what you were wanting?

Thank you for looking into this

comment:7 by digitall, 8 years ago

Owner: changed from djwillis to sylvaintv

comment:8 by digitall, 8 years ago

Summary: TOON: Game Freeze Talking To CareCrow (Caanoo)TOON: Game Freeze Talking To CareCrow

comment:9 by digitall, 8 years ago

Since this you can replicate this on a desktop build, reassigning to Toon engine developer as this is not a Caanoo specific issue.

Checked your datafile listing against my copy of Toonstruck EN...

The checksums for MISC/209_2M.SMK, MISC/209_3M.SMK, MISC/CREDITS.SMK and MISC/DREW.PAK do not match my version and you appear to be missing the contents of the ACT1 and ACT2 directories, so this looks like corrupt datafiles.

Please check the required datafiles from the link below and try recopying these from your CD media:
http://wiki.scummvm.org/index.php/Datafiles#Toonstruck

comment:10 by SF/foleyjo, 8 years ago

I may have done the md5 thing wrong because my act 1 and 2 folders do have all the contents!

Did it crash for you when you used the save file?

comment:11 by digitall, 8 years ago

No crash loading from the attached savegame.

comment:12 by digitall, 8 years ago

foleyjo: Can you please try checking the required datafiles from the link below and try recopying
these from your CD media as previously suggested:
http://wiki.scummvm.org/index.php/Datafiles#Toonstruck

If this still gives the same MD5sums and bug, then if you could identify your versions' cover art from the gallery here:
http://www.mobygames.com/game/toonstruck/cover-art
and also submit some information to allow us to identify which EN variant you have i.e. A CD Pressing ID (This would be the string of numbers around the CD centre)..

My variant is the Sold Out Software UK Release.

comment:13 by SF/foleyjo, 8 years ago

Hi
I'm very sorry but it seems my report was false. I've found out there is a problem with the SD card I was playing the game on. I recopied the files from the CD and the freezing stopped but then I got problems elsewhere. I have also come across issues with other software on the sd card which I don't get when using a different one.
Again I'm sorry.

comment:14 by digitall, 8 years ago

Resolution: invalid
Status: newclosed

comment:15 by digitall, 8 years ago

foleyjo: No problem. Thanks for bothering to follow up as some bug submitters go AWOL leaving us to guess :-)
Closing as invalid.

Note: See TracTickets for help on using tickets.