Opened 8 years ago

Closed 8 years ago

Last modified 11 months ago

#5942 closed defect (fixed)

ANDROID: no faked delay for clicks

Reported by: SF/amitloaf Owned by: fuzzie
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

Right click doesn't register in any way in Gobliiins, Gobliins 2, Goblins 3 and Woodruff. Makes Gobliiins unplayable in touchscreen-only devices such as Galaxy S2 as you can't switch verbs.

Ticket imported from: #3468449. Ticket imported from: bugs/5942.

Change History (17)

comment:1 by digitall, 8 years ago

Summary: Right click doesn't work on touchscreen only android devicesGOB: ANDROID: No Right Click on Touchscreen Devices

comment:2 by digitall, 8 years ago

amitloaf:
Thank you for your bug report, but can you provide the following information to help investigate this bug:

1. Can you confirm what version of ScummVM you are using?
I am assuming you are using the current stable release i.e. v1.4.0

2. Can you please confirm that you have read the Android control instructions here:
http://wiki.scummvm.org/index.php/Android

3. After reading 2, can you confirm that this is not a misunderstanding of how to do a right click?

4. Can you confirm if your device is multitouch?
If so, please note the different method for right click listed in 2.

5. If you are still having problems at this point, please can you test with the latest daily development build from:
http://buildbot.scummvm.org/builds.html
and report if the issue is still present.

6. Finally, please do a quick check with a desktop v1.4.0 build i.e. Win32, OSX or Linux to check that this is not
an issue with your game datafiles (unlikely, but should just check).

comment:3 by digitall, 8 years ago

Summary: GOB: ANDROID: No Right Click on Touchscreen DevicesANDROID: GOB: No Right Click on Touchscreen Devices

comment:4 by fuzzie, 8 years ago

Known issue with the gob engine expecting a delay between the mouse down and mouse up events, which doesn't happen with the (instant) touchscreen events. The iPhone backend solved this by artificially delaying the second event by a few milliseconds, the Android backend should probably do the same.

comment:5 by fuzzie, 8 years ago

Component: Engine: Gob
Game: Gobliiins
Owner: set to fuzzie
Summary: ANDROID: GOB: No Right Click on Touchscreen DevicesANDROID: no faked delay for clicks

comment:6 by digitall, 8 years ago

fuzzie: Thanks. For anyone who wants to look at implementing this, the iOS fix was b23dfd72f123c7d98c5076d813e522834888588a.

comment:7 by SF/amitloaf, 8 years ago

Yes i've done all those steps before reporting. Thank for your quick response and hope i'll be able to play those great games soon :)
If no-one has the time to work on that fix, I'll be happy to do it myself although I've never seen the code yet.

comment:8 by digitall, 8 years ago

amitloaf: Any patch to fix this would be gratefully received. Please feel free to attach a proposed patch to fix to this bug.

comment:9 by SF/amitloaf, 8 years ago

Can I get a small tutorial or something by someone?
Things I don't know:
- How to compile this for my android to check it
- How do I use that fix reference number to look at the patch fix for the iOS. Thank you!

comment:10 by digitall, 8 years ago

amitloaf: I assume that you are familar with C++ ?

All relevant documentation can be found at http://wiki.scummvm.org/index.php/Developer_Central
Android specific compilation instructions: http://wiki.scummvm.org/index.php/Compiling_ScummVM/Android

That number is not a bug/fix reference, but refers to a Git commit in our revision control system:
https://github.com/scummvm/scummvm/commit/b23dfd72f123c7d98c5076d813e522834888588a

comment:11 by fuzzie, 8 years ago

Also affected is Toonstruck (reported in #3483310), which is ignoring the mouse events completely and checking button state instead.

comment:12 by fuzzie, 8 years ago

Fixed in 4763b2c5, I hope. Gob works nicely for me now, anyway.

comment:13 by fuzzie, 8 years ago

Resolution: fixed
Status: newclosed

comment:14 by SF/dtelyukh, 8 years ago

When this fix will be released?
Thanks

comment:15 by digitall, 8 years ago

dtelyukh: This fix was applied to master and will be incorporated into the v1.5.0 release. Until then, you can try using a daily development build (which incorporates this):
http://www.scummvm.org/downloads/#daily

comment:16 by SF/dtelyukh, 8 years ago

tdhs: I uninstalled 1.4.0 and installed current version from master. After starting I had only black screen on my Acer Iconia Tab A501 (android 3.2). Scummvm from git doesn't work on my device.

comment:17 by digitall, 11 months ago

Component: Port: Android
Note: See TracTickets for help on using tickets.