Opened 8 years ago

Closed 6 years ago

#5864 closed defect (invalid)

RTZ: Can't take egg from Canuk's shack

Reported by: SF/abrasive Owned by: bluegr
Priority: normal Component: Engine: MADE
Keywords: original Cc:
Game: Return to Zork

Description

After finishing up in Canuk's shack, attempting to feed scroll to duck & take egg outside meet same response as trying to take bottle or scroll alone - the item reappears in the room and either "Egg disappears" or "Your bag seems lighter" is displayed (depending on whether you are holding the egg or no).

Game version is English RTZ CD, gog.com release - marked V1.1, 12/7/93
Running latest nightly ScummVM on OS X 10.6.

Ticket imported from: #3420541. Ticket imported from: bugs/5864.

Attachments (2)

rtz.025 (36.2 KB ) - added by SF/abrasive 8 years ago.
Savegame at the shack
rtz.016 (35.2 KB ) - added by bluegr 8 years ago.
Alternative savegame, after Canuk. Enter the shack to reproduce the problem

Download all attachments as: .zip

Change History (12)

comment:1 by SF/abrasive, 8 years ago

Summary: Can't take egg from Canuk's shackRTZ: Can't take egg from Canuk's shack

comment:2 by digitall, 8 years ago

JHL: Thank you for this bug report. Please can you attach a savegame to aid replication.

by SF/abrasive, 8 years ago

Attachment: rtz.025 added

Savegame at the shack

comment:3 by digitall, 8 years ago

Hmm, I'm getting the same issue as "RTZ: Item disappears - ID: 2826006" when loading the savegame i.e.
The attached savegame can not be loaded by current Git master development,
but this is likely to be due to the savegame being corrupt/older version.
The message produced is:
"WARNING: Unexpected save game size. Expected 91000, size is 90998!"

This was probably broken by 305954d34a612f14bdaad2cda9f982498f4f7066 by
bluegr.
Save game headers are now verified

svn-id: r35848

Though this may also be due to the slight difference in my game version:
Return to Zork - English CD version 1.0 9/15/93

comment:4 by digitall, 8 years ago

Owner: set to johndoe123

comment:5 by digitall, 8 years ago

john_doe: Could you try loading the attached savegame with the current Git master and your V1.1 or V1.2 and confirm whether this is just due to my game version, or whether we have an issue with truncated savegames from earlier builds?

FYI:
121bef4f79e23ad8ae569170d8375391f89b2aee
Author: Filippos Karapetis <md5@scummvm.org> 2011-10-09 23:48:47

MADE: Added missing finalize() calls to the game state saving code

Thanks to wjp for finding these

comment:6 by bluegr, 8 years ago

tdhs: the commit that you are referring to has nothing to do with the issue at hand. That commit adds verification checks for all saved games, it does not change the save format at all (as the commit message says "Save game headers are now verified" - not changed)

As for the version - you need to use the same game version as the one used in the saved games, AFAIK. Patch 1.2 can be found at:
http://www.patches-scrolls.de/return_to_zork.php

by bluegr, 8 years ago

Attachment: rtz.016 added

Alternative savegame, after Canuk. Enter the shack to reproduce the problem

comment:7 by bluegr, 8 years ago

Uploaded my save from this location

comment:8 by digitall, 8 years ago

Just to update status and clarify: It appears that RTZ English V1.0 and V1.1+ savegames are incompatible (Though v1.1 and v1.2 seem to be similar enough to not have issues). Since I only have RTZ v1.0 currently, and the v1.2 patch doesn't seem to work to update this, I don't think I can investigate this. Sorry.

comment:9 by bluegr, 6 years ago

Keywords: original added; script removed
Owner: changed from johndoe123 to bluegr
Resolution: invalid
Status: newclosed

comment:10 by bluegr, 6 years ago

This is normal game behavior, according to walkthroughs. You can't take the scroll out of the shack, either on its own or inside the duck's egg. The duck's egg is merely for fun, basically, in case you need the scroll again.

You don't need the scroll outside the shack anyway, it's only used for the "unduck" spell that frees Canuk.

Thus I'm closing this as invalid / occurs in the original

Note: See TracTickets for help on using tickets.