Opened 9 years ago

Closed 9 years ago

Last modified 22 months ago

#5863 closed defect (invalid)

Windows: Noisy Sound

Reported by: SF/swolffer Owned by: Kirben
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

First of all: I don't know anything about DirectSound But I can hear white noise in every game whenever there is sound. If the sound stops, the noise stops as well. WinAmp does have a checkbox "create primary buffer" saying that this fixes quality problems on old sound cards. I'm susing a SoundBlaster AWE32 Multi-CD in an ISA slot with Windows 98 and the latest drivers I cound find are from 1997. I guess this qualifies for "old sound card". Can you add an option for using a primary buffer (whatever that might be)?

Ticket imported from: #3419942. Ticket imported from: bugs/5863.

Change History (6)

comment:1 by Kirben, 9 years ago

Try the suggestion in section 5.16 of the FAQ on the ScummVM web site. Which can often help fix sound issues, on older sound cards under Windows.

comment:2 by SF/swolffer, 9 years ago

Okay, that does kill the noise, but it prevents any other application from using sound.

comment:3 by Kirben, 9 years ago

Closing as invalid, as this is a sound card drivers issue. Your sound card drivers lacks good support for DirectSound.

Using the 'waveout' sound option of SDL uses older sound APIs, and not DirectX. Which is why the sound is more limited I expect.

comment:4 by Kirben, 9 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:5 by Strangerke, 7 years ago

Component: --Unset--Ports

comment:6 by digitall, 22 months ago

Component: PortsPort: Win32
Note: See TracTickets for help on using tickets.