Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#586 closed defect (wontfix)

MI2 : unable to enter the protection code

Reported by: SF/yokitori Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

when I am prompted to enter the code, I'm just unable to do it, only the enter key does respond. I am using the latest win32 CVS (2.82 built on 23 november) and the french version of MI2. As far as I know the bug appeared in the latest releases but the last I had before was the one of the September 10th ... I allready tried to change the keyboard config from azerty to qwerty , to toggle numolck on or of, capslock etc.... but there is no way... I am using win XP Pro..

Ticket imported from: #642768. Ticket imported from: bugs/586.

Change History (14)

comment:1 by SF/yokitori, 17 years ago

in the version 2.82 from November 16 therz was not this problem...

comment:2 by SF/yokitori, 17 years ago

Summary: no key execpt the enter respond at proteMI2 : unable to enter the protection code

comment:3 by fingolfin, 17 years ago

Err... what?!? Previously I was told that the copy protection did not work *specifically* in the french version of ScummVM on a french keyboard. That's why I yesterday put a fix for this in CVS. Now you are telling me that it worked before, and now with the fix doesn't work anymore?!?! Something is really strange here...

comment:4 by fingolfin, 17 years ago

Owner: set to fingolfin

comment:5 by fingolfin, 17 years ago

Can you please tell me which keys exactly don't work?

Moreover, if you launch another Scumm game, does keyboard input in the F5 (save) menu work?

comment:6 by SF/yokitori, 17 years ago

Well this is some kind of weird thing, but is the fix you've done included in the Win32 Daily Snapshot that is available in the download secion, cause if it isn't, then the cause is simple and I should'nt have benn afraid of tat problem, but is it is, then maybe the problem depends on the operating system ? well I don't know that much how does all those things works...

comment:7 by SF/yokitori, 17 years ago

Well the only keys that work in MI2 are the "enter" and "escape" keys, (they stop the rollings objects) but no other seems to work (Even thought I don't really have any way to test them in that part of the game, but I'm sure that no numbers work, the one of the standard keyboard neither those of the numeric pad) And in others games like DOTT, all the keys seems to worl properly even the numbers (well not those of the numeric pad but the others ones) ...

comment:8 by fingolfin, 17 years ago

You are using latest CVS, so there is a simple way to find out:

Run scummvm with no parameters, you'll get into the launcher. Press "Add Game". Use the browser to select any of your scumm game data dirs.

Then it'll pop up a new dialog with two edit fields. Just try typing data into them, you should be able to find out which keys it understands. Or if it maybe "misunderstands some keys".

OH - and what version of SDL are you using?

comment:9 by SF/yokitori, 17 years ago

OH OK I finally found it, it was just a question of capslock, but it is weird that it was not the same in others version, and that in other games it works without capslock.... thank you

comment:10 by fingolfin, 17 years ago

So do you mean it works when you activate caps lock, but doesn't work if caps lock is off?

comment:11 by SF/arisme, 17 years ago

confirming this - the SDL_EnableUnicode broke it ... before this change, the keyboard input was behaving like a qwerty keyboard (but just for the numbers, I know it's strange ...). Now the keyboard behavior is correct but then SHIFT-number falls in the quick savegame code (which isn't very interesting here :))

I'd say that a good way to fix this could be to map the quick savegame key to CTRL-number and the quick loadgame key to ALT-number

comment:12 by SF/yokitori, 17 years ago

Well what seems weird to me is that to enter the protection code you have to enable the capslock, but when you are giving a name to a savegame you just have to use SHIFT+NUMBER, this is weird, but maybe it is cause MI2 only suport single entries keys for the protection....

comment:13 by fingolfin, 17 years ago

Ahh! See the whole situation now looks very diffrently: so numbers do work, except for the copy protection screen. OK. Since the copy protection code is done by the game scripts, I think we can't do much about it for now.

comment:14 by fingolfin, 17 years ago

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.