Opened 17 years ago

Closed 16 years ago

#587 closed defect (fixed)

FOA: Can't get eel in Iceland

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Indiana Jones 4

Description

Return to Iceland after getting the orichalcum bead
from Tikal; enter the ice cave. (Or use attached saved
game.) Use the orichalcum bead on the exposed eel
head. This should cause the eel head to melt itself
out of the ice, so you can get it. Instead, a
graphical glitch occurs, the orichalcum is removed from
your inventory, and the eel remains encased in the ice.
This bug thus prevents you from continuing/completing
the game.

I'm playing the English CD Talkie version of the game,
with the latest CVS: ScummVM 0.2.82 CVS Built on Nov 23
2002 11:25:48.

Ticket imported from: #642894. Ticket imported from: bugs/587.

Attachments (3)

atlantis.s02 (47.7 KB) - added by SF/dfabulich 17 years ago.
Saved game. Use the bead on the exposed eel head
eelbug.png (93.3 KB) - added by SF/dfabulich 17 years ago.
Screenshot of glitch
repro.txt (1.2 KB) - added by SF/dfabulich 17 years ago.
Walkthrough to bug

Download all attachments as: .zip

Change History (14)

Changed 17 years ago by SF/dfabulich

Attachment: atlantis.s02 added

Saved game. Use the bead on the exposed eel head

Changed 17 years ago by SF/dfabulich

Attachment: eelbug.png added

Screenshot of glitch

comment:1 Changed 17 years ago by SF/dfabulich

I'm attaching a screenshot of this effect as well.

comment:2 Changed 17 years ago by fingolfin

I can't open that save game, ScummVM tells me "invalid version".

From when is that savegame? Did you start to play atlantis
recently, or was the game leading to that save game started
a longer time ago?

comment:3 Changed 17 years ago by SF/dfabulich

It's a brand new game. I tried starting over to see if I
could reproduce the sub problem.

I'm very surprised that you can't open my saved games...
Perhaps I'll try reproducing this issue on another
machine...? What could cause this? I'm on Windows 2000
using the Win32 snapshot specified above. What are you using?

comment:4 Changed 17 years ago by eriktorbjorn

I can reproduce it with the attached savegame, at least.
I'll have to check later if I can also reproduce it when
playing from the beginning, and if I can at least figure out
*when* it broke.

Changed 17 years ago by SF/dfabulich

Attachment: repro.txt added

Walkthrough to bug

comment:5 Changed 17 years ago by SF/dfabulich

This bug is so early on in the game that I've attached
explicit instructions on how to reproduce the error from a
new game. See repro.txt.

comment:6 Changed 17 years ago by eriktorbjorn

Yup. Happens when I play it from the beginning as well. Time
for some regression testing, I guess...

comment:7 Changed 16 years ago by eriktorbjorn

The regression happens between revision 1.26 and 1.27 of
script_v1.cpp -- fingolfin's fix for bug #602351 (too many
fades in Zak256). There's actually an even earlier spot in
FOA where you can see the regression, and that's in the
intro when Indy opens the small statue.

Fingolfin, could you look into this one? I don't know the
details of the bug you were fixing.

comment:8 Changed 16 years ago by fingolfin

OK, I made that change conditional to small header games,
can you please check whether it fixes the FOA issue?

comment:9 Changed 16 years ago by eriktorbjorn

Works for me with the latest Windows snapshot (which was, of
course, compiled after your change), both with the intro and
the eel statue scene.

However, there appears to be a new regression: Some text
during the intro wasn't wrapped correctly. I didn't have the
time to look much at it, but some of Kerner's lines at the
very least. Could it be your recent cleanup of string.cpp?

comment:10 Changed 16 years ago by SF/dfabulich

I can confirm that this bug is gone in the latest snapshot:
ScummVM 0.2.82 CVS Built on Nov 27 2002 12:09:16. I've also
filed bug 644620 on the dialog.

comment:11 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.