Opened 8 years ago

Closed 4 years ago

#5858 closed defect (fixed)

AGI: Manhunter - No ENTER key after Launcher Load

Reported by: SF/swolffer Owned by: m-kiewitz
Priority: high Component: Engine: AGI
Keywords: Cc:
Game: Manhunter

Description

When starting Manhunter, the ENTER key works as expected. But when I save a game and restore it, pressing ENTER doesn't have any effects anymore. Using the cursor keys, however, works fine.
Manhunter English 1.22
ScummVM 1.3.1
Windows 98

Ticket imported from: #3417676. Ticket imported from: bugs/5858.

Attachments (3)

mh1.008 (4.3 KB ) - added by SF/swolffer 8 years ago.
debug.patch (622 bytes ) - added by digitall 8 years ago.
Debugging Patch
mh1.002 (5.6 KB ) - added by digitall 8 years ago.
Savegame for Replication

Download all attachments as: .zip

Change History (20)

by SF/swolffer, 8 years ago

Attachment: mh1.008 added

comment:1 by digitall, 8 years ago

Summary: No ENTER key after restoring gameAGI: No ENTER key after restoring game

comment:2 by digitall, 8 years ago

swolffer: I suspect that this bug has been fixed in the current development code i.e. 1.4.0pre by the following commit:
81fdf2c10306fa8d449476f6c77afb8299b93f4d

AGI: Fixed bug #3074570 - "AGI LSL1: TAB stops working after restart"

Applied eriktorbjorn's patch from that bug tracker item (slightly
modified), which is what NAGI does, and which fixes restarting in LSL1
and PQ1 (bug #2823762), and other AGI games that do not reset the
controller keys when restarting.

Please can you test with a daily development build and confirm if this bug is fixed as well?:
http://www.scummvm.org/downloads/#daily

comment:3 by digitall, 8 years ago

Resolution: outdated
Status: newpending

comment:4 by digitall, 8 years ago

Owner: set to digitall

comment:5 by SF/swolffer, 8 years ago

Status: pendingnew

comment:6 by SF/swolffer, 8 years ago

Tried 1.4.0git2598-gf20b8ec (Oct 7 00:18:58)
Bug still exists

comment:7 by digitall, 8 years ago

Owner: digitall removed
Resolution: outdated

comment:8 by digitall, 8 years ago

Replicated with latest Git master on Linux x86_32:
ScummVM 1.4.0git2604-g19cac9b-dirty (Oct 7 2011 01:33:47)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC

This occurs if you load a savegame from the launcher load button, but not if you start the game and then load from the AGI drop down menu. I suspect something is not being setup correctly when loading from the launcher.

comment:9 by digitall, 8 years ago

Summary: AGI: No ENTER key after restoring gameAGI: Manhunter - No ENTER key after Launcher Load

comment:10 by bluegr, 8 years ago

I can't reproduce this one. Tried loading from inside the game and from the launcher, and the Enter key still works for me...

comment:11 by digitall, 8 years ago

thebluegr: I can still replicate with the attached savegame.

I have debugged and found the cause to be _game.controllers[] are reset when loading from the launcher or command line i.e. ./scummvm -d 4 --debugflags=Input -x 2 mh1, but not if I load with F7 within the game.

Attaching a debug patch to help you check.

by digitall, 8 years ago

Attachment: debug.patch added

Debugging Patch

by digitall, 8 years ago

Attachment: mh1.002 added

Savegame for Replication

comment:12 by sev-, 7 years ago

Owner: set to sev-

comment:13 by sev-, 7 years ago

Priority: normalhigh

comment:14 by m-kiewitz, 4 years ago

Owner: changed from sev- to m-kiewitz

comment:15 by m-kiewitz, 4 years ago

this bug seems to be solved in my current work-in-progress graphics rewrite.
Marking for later.

some information (so called controllers) was not saved by ScummVM, that's why This information is now saved in my current work-in-progress rewrite.

comment:16 by m-kiewitz, 4 years ago

This is now fixed by commit 8a595e7771aa89d06876e13d7ab6751e26da8982

But see above, old saves will require the user to for example go through copy protection, so that the controllers are set up.

comment:17 by m-kiewitz, 4 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.