Opened 9 years ago

Closed 9 years ago

Last modified 20 months ago

#5859 closed defect (fixed)

Windows: Mouse stuck after exit

Reported by: SF/swolffer Owned by: Kirben
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

Somethimes exiting ScummVM causes the mouse pointer to be stuck at its current location. Keyboard works fine, though. Doesn't happen on every exit. Does not require a game to be run. Workaround: Press Ctrl+Alt+Delete, then Escape ScummVM 1.3.1 on Windows 98 Does not happen in 1.1.148874, haven't tried any versions between those two.

Ticket imported from: #3417682. Ticket imported from: bugs/5859.

Change History (9)

comment:1 by digitall, 9 years ago

swolffer: Unsure what might be causing this. We are doing some investigation. Can you please try this with a daily development build i.e. v1.4.0pre and thus confirm if this is still occuring in the latest code?: http://www.scummvm.org/downloads/#daily Also, please try both the buildbot development Win32 build and Kirben's Win32 builds...

comment:2 by digitall, 9 years ago

Also, can you confirm how you exit ScummVM in the troublesome cases? By the X in the top-right, by Quit button on launcher or keystroke? Also, are you using noconsole i.e. hiding of DOS-type console?

comment:3 by SF/swolffer, 9 years ago

No hidden status window. Doesn't seem to matter if I exit by Alt+X in an AGI game, by the X-Button on the Window or by clicking the Quit button in the GUI without even loading a game.

Tried 1.4.0git2598-gf20b8ec (Oct 7 00:18:58) from http://www.scummvm.org/downloads/#daily: Exited ten times using the Quit button in the GUI, mouse pointer got stuck every time.

Tried 1.4.0git2595-g43f45ce (Oct 6 2011 05:13:53) from http://buildbot.scummvm.org/builds.html: Exited about 20 times using the Quit button in the GUI, mouse pointer never got stuck.

Tried to find Kirben's builds, but got stuck in useless Google results. :-)

comment:4 by Kirben, 9 years ago

The Windows builds at http://www.scummvm.org/downloads/#daily are my builds.

Try using the SDL runtime (SDL-1.2.14-win32.zip) for Windows, from http://www.libsdl.org/download-1.2.php with my Windows build. Just overwrite the SDL.dll file in the directory, where ScummVM is located.

Please let us know if that cures the problem in my Windows builds.

comment:5 by SF/swolffer, 9 years ago

That's it. I replaced the SDL.DLL of 1.3.1 release and 1.4.0git2598-gf20b8ec and exited both of them 20 times without a problem.

comment:6 by Kirben, 9 years ago

The SDL runtime I use includes minor changes, to fix an input regression in the current release for Windows. Unfortunately looks like these changes cause further issues to occur.

My Windows daily snapshots will include the standard (unchanged) SDL runtime again, so this issue will no longer occur.

comment:7 by Kirben, 9 years ago

Component: --Unset--
Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:8 by Strangerke, 7 years ago

Component: --Unset--Ports

comment:9 by digitall, 20 months ago

Component: PortsPort: Win32
Note: See TracTickets for help on using tickets.