Opened 8 years ago

Closed 7 years ago

Last modified 2 years ago

#5857 closed defect (worksforme)

NIPPON: no sound in dos version

Reported by: SF/windlepoons Owned by: bluegr
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

no sound in Multi-linguage DOS version.

tested from ScummVM 0.11.1 > ScummVM 1.4.0git2532-gb4e6962

console: WARNING: unknown character '' in DosSoundMan_ns_ns::playCharacterMusic!

Ticket imported from: #3416863. Ticket imported from: bugs/5857.

Attachments (1)

checksum.md5 (2.0 KB ) - added by SF/windlepoons 8 years ago.
md5 checksums Multi-language DOS

Download all attachments as: .zip

Change History (9)

by SF/windlepoons, 8 years ago

Attachment: checksum.md5 added

md5 checksums Multi-language DOS

comment:1 by bluegr, 8 years ago

Sound is working fine for me, at least in rooms that do have sound. Can you give more details regarding the OS you're using? What are your sound settings in ScummVM? Which room are you in that has no sound? (not all rooms in Nippon Safes have music, some are completely silent)

comment:2 by SF/windlepoons, 8 years ago

With DOSBox when start nippon and select language then "peep" & permantenly background sounds.
here a youtube video for example: http://www.youtube.com/watch?v=bPKY_RuDPfM
I tested all Audio settings in Scummvm but not sound/music in nippon.

OS:aptosid 64-bit (Debian unstable)

comment:3 by bluegr, 7 years ago

Just tried this again, and music plays fine, both with General MIDI and Adlib music settings in ScummVM.

Try starting the game with Dough Nuts (smart). The first scene is outside the prison, where you need to go to the payphone and call a taxi. Is music working for you in these scenes? If not, try adjusting the music volume and make sure you haven't muted the sound. The music file for these scenes is "nuts.mid" - try recopying it from the original game files

comment:4 by bluegr, 7 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:5 by bluegr, 7 years ago

Status: newpending

comment:6 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: worksforme
Status: pendingclosed

comment:7 by bluegr, 7 years ago

Despite requesting a status update, no further information
on this tracker item has been provided.

As a consequence, I am now closing this item as "Out of
Date". Should you feel that this is not justified, feel free
to re-open it while providing a status update at the same
time, so that we can properly re-evaluate it.

Thank you.

comment:8 by domino1983, 2 years ago

Summary: NIPPON: no sound in dos versionNIPPON: no sound in dos version

I think there is still some problem with DOS music. DOS version should play music in intro, but there is a message:
WARNING: unknown character in DosSoundMan_ns_ns::playCharacterMusic!

With default music setting (I guess it's the same as AdLib) the intro music volume is extremely low.
With Windows MIDI setting the intro music plays just fine.
With MT-32 emulation setting there is only one note playing.

I'm using latest daily build for Win32.

Note: See TracTickets for help on using tickets.