Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#577 closed defect (worksforme)

FOA: Sub won't enter Atlantis

Reported by: SF/dfabulich Owned by: SF/ender
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Playing on the team path, I can't get the sub to go
into the entrance to Atlantis. I'm using ScummVM
0.2.82 CVS, Built on Nov 16 2002 20:12:45.

I just went back and replayed this in DOS, and found it
to be trivially easy; as soon as the sub gets close to
the entrance, the game is supposed to automatically
take control and guide the sub in. [You have to use
the rudder to get the sub as close to the camera as
possible, then go back one rudder-turn, get the ship at
more-or-less the same depth as the entrance, then
approach the entrance from the right.]

Saved game attached.

Ticket imported from: #639640. Ticket imported from: bugs/577.

Attachments (1)

atlantis.s04 (66.6 KB ) - added by SF/dfabulich 17 years ago.
Saved game right before sub entry

Download all attachments as: .zip

Change History (17)

by SF/dfabulich, 17 years ago

Attachment: atlantis.s04 added

Saved game right before sub entry

comment:1 by fingolfin, 17 years ago

Priority: normalhigh
Summary: Indy4: Sub won't enter AtlantisFOA: Sub won't enter Atlantis

comment:2 by SF/ender, 17 years ago

Count me out for looking for this one, I've never been able to get
past annoying 'actionish' scenes like this anyway.

I don't suppose you remember if earlier versions of ScummVM
work? Is this a recent issue, and if so can anyone remember a
rough timeframe (within a month is fine ;) of when it broke?

comment:3 by SF/dfabulich, 17 years ago

This was my first time playing FOA on Team mode in ScummVM,
but andrej4000 supposedly did it on 11/5 (!!!). That
suggested to me that maybe this was my mistake, but after
trying it a few times in DOS, I can't see how that could be.

Also, inguin reported beating the game on Team path in this
thread:
https://sourceforge.net/forum/forum.php?thread_id=765362&forum_id=115756

Basically, everything I see suggests to me that it *ought*
to be user error on my part, but I've checked and
double-checked and now I need somebody else to try to
confirm/deny with my saved game.

comment:4 by fingolfin, 17 years ago

I can't load the file, it seems:

Error(66:207:0x19195): Value 2608 is out of bounds (0,2047)
int script(207) msg Bit variable %d out of range(r)!

also tried a german FOA version (you didn't mention what
language you use :-), but that gives me a similiar error:

Error(66:214:0x199FF): Value 1795 is out of bounds (0,799)
int script(214) msg Variable %d out of range(w)!

comment:5 by SF/jamieson630, 17 years ago

Firstly, there are multiple entrances in the team path, picked
at random. Some are further from the "camera" than others,
and are pointing in different directions.

Note that there is one constant to every entrance: you have to
BACK into the entrance. You can never go forward into it.
They did this so that you have to find the forward/reverse
switch before you can successfully enter the lost city.

Last time I did it, the game did automatically "grab" the sub
and pull it in once I was at the right z-layer, going backwards
at somewhere near the depth of the entrance.

comment:6 by SF/dfabulich, 17 years ago

fingolfin: I just re-downloaded my saved game and tried it
again with the latest Win32 snapshot. (I am playing in
English.) The saved game loads fine... I still can't enter
Atlantis.

comment:7 by SF/dfabulich, 17 years ago

jamieson630: I just played it through *again* in the DOS
version; you do *not* need to back into the entrance.
Furthermore, there doesn't seem to be anything "random"
about it. You just drive the sub into the little hole on
the left hand side of the screen.

comment:8 by SF/dfabulich, 17 years ago

Oh, to be absolutely precise, I'm using the English CD
Talkie version. (The one that comes in the adventure pack
that LucasArts is still selling.) All files are copied to
my hard drive.

comment:9 by SF/sir_kill_a_lot, 17 years ago

I downloaded the savegame and tried it with FoA English
Talkie and latest CVS (ScummVM 0.2.82 CVS Built on Nov
26 2002 12:20:05) but I had no problem entering the air lock!

I tried it 4 times and it always worked, you can enter it in
both directions, backward and forward.

Either it's fixed now or it was never broken...

comment:10 by SF/jcapper, 17 years ago

I am using the English Talkie CD, and had no problem using
getting the savegame sub into the airlock.

comment:11 by SF/dfabulich, 17 years ago

Well, I still can't do it with my old saved game, but with
the latest Win32 snapshot [ScummVM 0.2.82 CVS Built on Nov
27 2002 12:09:16] I managed to restart the game from scratch
and drive the u-boat through the hole. I agree that this
was either fixed (surely that was it!) or it was never
broken (which I was afraid of to begin with).

comment:12 by SF/sir_kill_a_lot, 17 years ago

I tried your savegame with an older version I found
(ScummVM 0.2.81 CVS Built on Nov 11 2002 13:29:18) and,
you won't believe, but there were no problems. It seems to be
that it was never broken, I still can easily get into the airlock.
(see screenshot:
http://members.chello.at/sir_kill_a_lot/images/airlock.png )

Are you sure you try to enter the right hole? When you move
the mouse cursor over it, it should display "air lock".

comment:13 by SF/dfabulich, 17 years ago

I'm sure I'm trying to enter the right hole, since I can do
it in DOS and I can do it with the current snapshot. [shrug]

Regardless of whether there ever *was* a bug, it's clear
that this bug is now closable.

comment:14 by SF/ender, 17 years ago

Alright then.

Bug closed as unreproducable.

comment:15 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: worksforme
Status: newclosed

comment:16 by SF/sir_kill_a_lot, 17 years ago

Yeah but you said you still can't do it with your old save
game, so I thought you maybe tried the wrong entrance :-)

Note: See TracTickets for help on using tickets.