Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5757 closed defect (fixed)

DW1: Cannot enter Act IV (six hero objects taken)

Reported by: SF/cymerio Owned by:
Priority: normal Component: Engine: Tinsel
Keywords: script Cc:
Game: Discworld

Description

I collected the 6 hero items required: soot, Offler's eye, moustache, tattoo, magic spell, and a sword that goes 'Ting'. I followed a walkthrough for that. But Act IV never kicks in.

I noticed that the gate guards' talk lines reset to those of Act 2 (they want to detain me for laziness). I no longer get the talk line about probabilities.

Version of the game: CD/DOS/Spanish Platform: Linux 64bit ScummVM 1.3.0svn (Apr 29 2011 18:24:08) Features compiled in: FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth

Ticket imported from: #3316921. Ticket imported from: bugs/5757.

Attachments (3)

dw.017 (4.2 KB ) - added by SF/cymerio 9 years ago.
Savegame with the 6 items in Act 3.
dw.012 (4.3 KB ) - added by digitall 9 years ago.
Savegame for DOS English showing same issue
dw.014 (4.3 KB ) - added by digitall 8 years ago.
Savegame for DOS English for replication / bisection.

Download all attachments as: .zip

Change History (14)

by SF/cymerio, 9 years ago

Attachment: dw.017 added

Savegame with the 6 items in Act 3.

comment:1 by digitall, 9 years ago

DeiF: Thank you for this bug report. Replicating this might take a while as few developers have the non-English versions of the game, so please be patient.

It would help us if you could try to replicate this bug as follows: 1. From the savegame, using the latest development build, available here: http://buildbot.scummvm.org/builds.html 2. If 1) still shows the bug: From a clean game start with the same build. 3. If 2) still shows the bug: From the savegame, using release v1.2.1 : https://sourceforge.net/projects/scummvm/files/scummvm/1.2.1 4. If 3) still shows the bug: From a clean game start using release v1.2.1 5. If 4) still shows the bug: From the savegame, with v1.3.0 on a 32-bit machine. 6. If 5) still shows the bug: From a clean game start, with v1.3.0 on a 32-bit machine. 7. if 6) still shows the bug: please repeat steps 3 & 4 for all previous releases backwards for all previous releases back to v1.0.0rc1 (which was the first release with the DW1 engine).

The idea is to determine if this is a regression since a previous released version and to locate when it was introduced and whether it is linked to a 32bit/64-bit issue.

comment:2 by digitall, 9 years ago

Also, to be clear: Which Linux distribution are you using? Did you install the v1.3.0 from your distribution packages or from a download from http://www.scummvm.org, and if so: which exact package did you download?

comment:3 by digitall, 9 years ago

Trying to replicate with Discworld (CD/DOS/English). Could you attach a link to the walkthrough you are using?

Also, could you try from your savegame the following: Speak to The Old Timers (Market Square), The Amazon Warrior (Market Square), The Wizards (Unseen University - Dining Room), Big Sally (Shades - House of Negotiable Affection) and Nobby (Guard at City Gate) and ensure you have triggered the reason why you have collected each time and solved Nobby's puzzle. This may then trigger the end of Act 3.

comment:4 by digitall, 9 years ago

Hmm, have managed to replicate this with Discworld/DOS/English with: ScummVM 1.4.0git1299-gf090eb6-dirty (Jun 17 2011 01:28:09) Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC

Attaching savegame at end of Act 3 with 6 items and after solving Nobby's puzzle, but still no Act 4.

This may be an original script bug, Will need to try restoring back to start of Act 3 and solving Nobby's Puzzle prior to acquiring the 6 items to see if this then works. This still might be a regression..

by digitall, 9 years ago

Attachment: dw.012 added

Savegame for DOS English showing same issue

comment:5 by SF/cymerio, 9 years ago

Sorry for haven't contacted you guys sooner, but I'm pretty busy these days (until mid-July). My distro is OpenSuse 11.4, and ScummVM comes from the official "games" repository.

When I was playing I noticed a lot of bugs. Far more than the wiki says. For example, once I managed to repeatably crash the game (ScummVM closed each time). However I don't remember what I did and just continued normally. Whatever was I doing it wasn't required for completing the game, and I was in a hurry, so I just continued playing (sorry, should have reported the crash).

Also, I noticed plenty of characters disappearing and appearing in some situations.

I remember another: when you have to brush the bumper bar of the donkey cart and examine it (right-click), then if you examine it another time, this time without brushing it, the bumper bar appears dirty again.

Back on the original problem. When I was playing I first talked with all the relevant characters that told me what items an hero should have. Then talked to Nobby and solved the 1-million-to-one quiz. While searching for the items (had 2 or 3 of them at that time), I remember that I talked again to Nobby, and the talk line was different. I continued searching for the items though, but it didn't work, as I stated.

I remember the original DOS game to be also buggy as hell, so maybe is not the fault of ScummVM.

comment:6 by digitall, 9 years ago

Thanks for the update. I still get a similar issue loading from near end of Act3. This is probably a regression since v1.2.1 due to Tinsel Engine fixes for other issues. Will bisect likely issues and playtest looking for this (time consuming, so will take some time).

@DeiF: If you get time, information on whether this occurs during a playtest on v1.2.1 from savegame and clean state would be useful.

comment:7 by digitall, 8 years ago

DeiF: Don't worry. Have found cause of regression.

Have bisected for the issue. This was introduced by: commit 9573b1d2f54818f9bdac4a91e0a90b306ade7810 Author: David Turner <digitall@scummvm.org> Date: Sun Jan 30 23:21:40 2011 +0000

TINSEL: Memory Leak Fix in Coroutines.

This fixes the leak from the COR0_BEGIN_CODE macro's CoroContextTag allocation. Setting the _sleep value to negative values prevented the deallocation of these. Have tested for obvious regressions, but a full DW/DW2 playtest should be done to confirm that this doesn't cause any issues. Thanks to fingolfin for indicating this solution.

svn-id: r55671

Attaching savegame to allow easy replication. Just load savegame and walk out of the mine. The game then should automatically switch to the Market Square for Act 4 intro.

Will try to locate the reason for this regression.

by digitall, 8 years ago

Attachment: dw.014 added

Savegame for DOS English for replication / bisection.

comment:8 by digitall, 8 years ago

Fixed by fuzzie in 0269a8d9008f51cca63ad215bbb2aa23ad75d574 (and 6318758e7119d7834a9f7c4be11b819ee0bfaff4 should correctly fix the memory leakage from CoroContextHolder).

Have playtested DW1 with this from start and game is completable. This fix has been scheduled for v1.3.1 release. Closing...

comment:9 by digitall, 8 years ago

Status: newclosed

comment:10 by digitall, 8 years ago

Resolution: fixed

comment:11 by lordhoto, 8 years ago

Summary: Cannot enter Act IV (six hero objects taken)DW1: Cannot enter Act IV (six hero objects taken)
Note: See TracTickets for help on using tickets.