Opened 8 years ago

Closed 8 years ago

#5758 closed defect (fixed)

WinCE: Pharkas: Sepia image doesn't change to full color

Reported by: SF/andrea2054 Owned by: CeRiAl
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

At the beginning of the game, just after the title of the Act I, the image appears with sepia tonality, then it should change to a full color image.
But the transition does not happen; music and animations play, but the cursor and the game controls do not appear, so the game is unplayable.
Loading a savegame will skip the transition and bypass the problem.
Verified with 1.3.0 and 1.3.0pre105-g2443bc6

HP iPAQ h2200 PocketPC running Windows CE 4.20

Ticket imported from: #3317300. Ticket imported from: bugs/5758.

Change History (9)

comment:1 Changed 8 years ago by SF/andrea2054

Summary: WinCE: sepia image doesn't change to full colorWinCE-Pharkas:sepia image doesn't change to full color

comment:2 Changed 8 years ago by wjp

Summary: WinCE-Pharkas:sepia image doesn't change to full colorSCI: WinCE-Pharkas:sepia image doesn't change to full color

comment:3 Changed 8 years ago by lordhoto

Summary: SCI: WinCE-Pharkas:sepia image doesn't change to full colorWinCE: Pharkas: Sepia image doesn't change to full color

comment:4 Changed 8 years ago by digitall

Owner: set to CeRiAl

comment:5 Changed 8 years ago by digitall

cerial23: I assume this might be fixed by your work on the backend.

andrea2054: Can you test with the latest development daily build and see
if this is still occuring for you?:
http://buildbot.scummvm.org/builds.html

comment:6 Changed 8 years ago by CeRiAl

tdhs: yes, right, according to my tests this bug was caused by the faulty timer in the 1.3.0 release. It works correctly now in 1.3.1 and "unstable".

comment:7 Changed 8 years ago by SF/andrea2054

I confirm, now it works in version 1.3.1

comment:8 Changed 8 years ago by SF/andrea2054

Resolution: fixed

comment:9 Changed 8 years ago by CeRiAl

Status: newclosed
Note: See TracTickets for help on using tickets.