Opened 8 years ago

Closed 8 years ago

#5756 closed defect (fixed)

SCUMM FM-TOWNS ANDROID: color mode not supported

Reported by: SF/bodoriffer Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Since version 1.3.0 for android (wich now has 16 bit support) the game does fail with "color mode not supported".
According to Fuzzi (http://forums.scummvm.org/viewtopic.php?p=67737#67737) this is caused by a different color packing than expected.
Instead turning to 256 colors the game closes.

Ticket imported from: #3316738. Ticket imported from: bugs/5756.

Attachments (1)

20110616195742.png (39.6 KB ) - added by SF/bodoriffer 8 years ago.
thats how it loola like

Download all attachments as: .zip

Change History (17)

comment:1 by athrxx, 8 years ago

Owner: set to athrxx
Resolution: fixed
Status: newpending

comment:2 by athrxx, 8 years ago

I have now added a fallback for this in the SCUMM engine (although normally it should not happen that a port has 16bit color mode enabled without actually fully supporting it).

Please test with a daily build if possible (http://buildbot.scummvm.org/builds.html). I cannot test Android.

comment:3 by SF/bodoriffer, 8 years ago

Had a negative test just now but I think will have to wait until tomorrow because the daily seems more like a nightly build to me. ;-)

comment:4 by SF/bodoriffer, 8 years ago

Status: pendingnew

comment:5 by athrxx, 8 years ago

Summary: color mode not supportedSCUMM FM-TOWNS ANDROID: color mode not supported

comment:6 by athrxx, 8 years ago

I have now made another change which tries other 16bit color modes after the default mode (which is apparently not supported by Android) fails.
When you test, make sure to select the development build (I haven't added this to the 1.3.1 branch yet, but I will if your test is positive).

comment:7 by SF/bodoriffer, 8 years ago

Downloaded from http://buildbot.scummvm.org/snapshots/master/android-master-latest.tar.bz2

No progress here because the android-master is dated 2011-06-15 05:46 - maybe the build job failed?

comment:8 by SF/bodoriffer, 8 years ago

No luck yet.

After seeing there was a fresh build right now I had no luck running Zak. The dialog "color mode not supported" does not show up this time but the graphic in FMTOWNS mode is totally broken. First there comes a black screen and later on you can see something like a writing - it "next morning" in ugly colors and in a double version.

comment:9 by athrxx, 8 years ago

Thanks for your testing.

The colors don't happen to look like in the screen shot here?
http://forums.scummvm.org/viewtopic.php?t=10361&postdays=0&postorder=asc&start=0

Could you please make a screenshot?

by SF/bodoriffer, 8 years ago

Attachment: 20110616195742.png added

thats how it loola like

comment:10 by SF/bodoriffer, 8 years ago

Thanks for your great support!
I have now a screenshot attached.

comment:11 by athrxx, 8 years ago

Okay, this looks bad.

I made another change which you can try out whenever buildbot decides to pick it up (probablly tomorrow afternoon ;-) ).

If this again doesn't help I might just set the mode back to 8bit for Zak on Android in the upcoming bugfix release.

comment:12 by SF/bodoriffer, 8 years ago

Hello!

The good thing is, the job ran this night. :-)

The bad thing is I am sorry to say but the new version (from this night) looks exactly as in the screenshot.

Think it would be better to just fall back to 8bit color for FM-TOWNS.

Best regards!

comment:13 by athrxx, 8 years ago

Fortunately I found a developer on the team who can actually test Android herself. We have found the issue and fixed it. Zak seems to run fine for her now on Android.

Please try once more as soon as buildbot picks it up ;-)

comment:14 by SF/bodoriffer, 8 years ago

Now it works! Many, many thanks to you and the other developers!

comment:15 by SF/bodoriffer, 8 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:16 by SF/bodoriffer, 8 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.