Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5201 closed defect (fixed)

MANIAC: No PCjr music in Maniac Mansion + other SCUMM games

Reported by: eriktorbjorn Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Current ScummVM SVN

It seems that whether or not you select "PC Speaker" or "PCjr", the SCUMM engine will pick PC Speaker sound. You can try this with Maniac Mansion (both versions, I suppose), but probably also with a couple of other games. I'm not entirely sure which games are supposed to be able to play PCjr music and which aren't. I think, but am not sure, that this is because the game's detection entries only have the MTD_PCSPK flag, not the MTD_PCJR flag, but is adding the extra flag the correct solution or not?

See also: http://forums.scummvm.org/viewtopic.php?t=9140

Ticket imported from: #3041539. Ticket imported from: bugs/5201.

Change History (9)

comment:1 by fingolfin, 9 years ago

Florian, can you please take a look, this sounds like yet another regression from the MIDI changes.

comment:2 by fingolfin, 9 years ago

Owner: set to athrxx

comment:3 by athrxx, 9 years ago

I fixed a wrong switch entry in scumm.cpp and added MTD_PCJR flags for Maniac Mansion and ZakMcKracken, v1 and v2. These targets seem to work fine now with pcjr setting.

I don't know whether this is relevant for other targets, too (loom, indy3, monkey1?). If someone knows/thinks that this is the case, he might consider adding the appropriate MTD_PCJR flags in detection_tables.h.

comment:4 by eriktorbjorn, 9 years ago

I've made some further adjustments to allow selecting PCjr music for the remaining games that support it that I know of (and which ScummVM supports it for), and added the MDT_PCJR flag for them.

As far as I can tell, only the Apple II and C64 versions of Maniac Mansion still only have the MDT_PCSPK flag. I have no idea whatsoever about them. Anyone?

comment:5 by athrxx, 9 years ago

I could add new MDT flags and devices for these. The devices wouldn't be able to create drivers, though. This is only possible for drivers which inherit from the MidiDriver abstract. But at least we'd have proper sound option entries in the gui.

Apple music seems to be unsupported atm, anyway (at least there is a TODO line in scumm.cpp about this).

comment:6 by athrxx, 9 years ago

Okay, I added devices, music type, GUIO flags etc. for C64, Amiga and AppleIIGS. While this does not improve audio support at all, it makes things at least more reasonable.

comment:7 by eriktorbjorn, 9 years ago

So does that mean everything about this has been fixed now, and that it can be closed?

comment:8 by athrxx, 9 years ago

I think so. I'll close this item as fixed. If you find other stuff you'd like to have fixed or changed just open up a new tracker item (or contact me via email). I am on vacation for the next 2 weeks, though.

comment:9 by athrxx, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.