Opened 9 years ago

Closed 9 years ago

#5200 closed defect (outdated)

KQ1SCI: Game hangs after goat offs troll

Reported by: SF/musiclyinspired Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: King's Quest 1

Description

This didn't happen on my first playthrough, but on my second playthrough to achieve full points I tried to off the troll with the goat and after the goat walks away off screen control is never given back to the player. As if the game is still waiting for something to happen. I tried restoring to an earlier save and even restarting my whole game. When I restored an earlier game the music that plays in this scene fades out and control is never returned to the player. When I restarted my game and tried it the music doesn't fade out and just keeps playing after the goat is gone and control is still not turned over to the player. Attached is a save game.

Ticket imported from: #3041352. Ticket imported from: bugs/5200.

Attachments (1)

kq1sci.001 (15.0 KB ) - added by SF/musiclyinspired 9 years ago.

Download all attachments as: .zip

Change History (7)

by SF/musiclyinspired, 9 years ago

Attachment: kq1sci.001 added

comment:1 by m-kiewitz, 9 years ago

I just tried, worked fine.
Please try on latest revision. Maybe this was a regression that was already fixed.

comment:2 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: outdated
Status: newpending

comment:3 by SF/musiclyinspired, 9 years ago

Done. Game is now completable with full points. Cheers.

comment:4 by SF/musiclyinspired, 9 years ago

Status: pendingnew

comment:5 by SF/musiclyinspired, 9 years ago

I was using the latest version at the time, though.

comment:6 by sev-, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.