Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5060 closed defect (fixed)

PHARKAS: Mouse and hotspot errors

Reported by: SF/kuroshiro Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

Freddy Pharkas Frontier Pharmacist (CD/DOS/English)
ScummVM 1.2.0SVN 51504
Windows 7 x64

When you try to place the ladder against the water tower, the mouse will start acting weird (right clicking no longer changes icons) and only a few hotspots will work. It's kind of hard to describe. Check the included save to see what I mean.

Ticket imported from: #3037192. Ticket imported from: bugs/5060.

Attachments (2)

freddypharkas.002 (67.3 KB ) - added by SF/kuroshiro 9 years ago.
place the ladder on the water tower
FPSG.000 (10.9 KB ) - added by SF/kuroshiro 9 years ago.
dosbox save game at the tower

Download all attachments as: .zip

Change History (15)

by SF/kuroshiro, 9 years ago

Attachment: freddypharkas.002 added

place the ladder on the water tower

comment:1 by digitall, 9 years ago

Replicated with r52030 on Linux x86_32.
Problem is as described and prevents game progression beyond the middle of Act 2.

Room is 320. bt shows scripts 0, 994 and 996 running.

Running under valgrind shows no memory access issues, but does allow correct behaviour.
This seems to indicate that a script timing interaction is the cause of this issue.

comment:2 by m-kiewitz, 9 years ago

It's possible to pick up the ladder after climbing it. The game will then act normally again.

comment:3 by m-kiewitz, 9 years ago

the ladder on screen is the actual problem. It seems to be calling kGetEvent as well, so it depends on luck where the event will land

comment:4 by m-kiewitz, 9 years ago

could you please play through this under sierra sci till that place - then switch dosbox to max cycles and try it as well (or even upload the sierra sci saved game here).

Maybe it just worked in sierra sci by accident, because in a slowed-down dos-box the animation will take plenty of time, so both kGetEvents would occur almost instantly and the first call (the actual game one, not the ladder one) would get the events most of the time.

comment:5 by SF/kuroshiro, 9 years ago

The whole sequence works fine in Dosbox regardless of what the cpu cycles are set at. Attaching a save game.

by SF/kuroshiro, 9 years ago

Attachment: FPSG.000 added

dosbox save game at the tower

comment:6 by SF/kuroshiro, 9 years ago

Btw, the only way to get clicks to properly register when this bug is happening is to quickly right click then left click. If you do it with just the right timing it will work.

comment:7 by m-kiewitz, 9 years ago

it's also possible to fast left-click. Like i said, random decides where the event goes currently and if it goes to the ladder, the event will be lost. Thank you for the saved game.

comment:8 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz

comment:9 by bluegr, 9 years ago

Perhaps the cleanest solution to this would be to remove the buggy kGetEvent calls from the ladder's associated scripts?

comment:10 by m-kiewitz, 9 years ago

i'm not sure. If sierra sci doesn't have problems with it, we shouldn't have problems with it either. I don't even understand why they are calling kGetEvent separately.

comment:11 by m-kiewitz, 9 years ago

qfg1vga does the same thing during fighting - ffs. bug #3036756

comment:12 by m-kiewitz, 9 years ago

if you change dosbox to maxcycles, the issue somewhat also occurs in sierra sci, but not as often. Anyway, it's now patched - fixed in r52362

comment:13 by m-kiewitz, 9 years ago

Keywords: original added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.