Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5059 closed defect (fixed)

PHARKAS: "Score" sound doesn't play

Reported by: SF/kuroshiro Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

Freddy Pharkas Frontier Pharmacist (CD/Dos/English)
Scummvm 1.2.0SVN 51505
Windows 7 x64

A fairly minor bug but kind of weird. I didn't notice it at first since it's been a while since I played the game in the original interpreter, but in ScummVM the "Score" sound whenever you get points does not play. Not sure if this is also a problem in the floppy version. I think I might have that version backed up somewhere so I will try to check it later.

Ticket imported from: #3037161. Ticket imported from: bugs/5059.

Change History (8)

comment:1 Changed 9 years ago by SF/kuroshiro

Confirmed that the sound *does* play in the floppy version.

comment:2 Changed 9 years ago by SF/kurufinwe

I encountered the exact same bug in QG3 (v. 1.1). However, I should add that (in QG3 at least) it ONLY affects the GM and MT32 drivers. With the Adlib driver, the "score" sound plays fine.

(Other SCI1 games, such as KQ5 and KQ6CD are unaffected, so it doesn't affect all of them.)

I'm reporting this here since it seems related, but I can file a separate bug for QG3 if necessary.

comment:3 Changed 9 years ago by m-kiewitz

just a note: it actually does play, but with volume set to 0.

comment:4 Changed 9 years ago by SF/kuroshiro

Er, ok. That's not very useful though. ;)

Playing through the game a bit in Dosbox reveals that a bunch of other sound effects don't play properly, like the little click when you select icons, hammering, maybe some other stuff.

comment:5 Changed 9 years ago by m-kiewitz

i just debugged sierra sci. In sierra sci the "vol" selector is set to 0x7f (which is highest volume). I have no real clue why that is. The calling code for the points sound will set "vol" to 0.

comment:6 Changed 9 years ago by m-kiewitz

Owner: set to m-kiewitz

comment:7 Changed 9 years ago by m-kiewitz

partly fixed by r52568 and finally fixed by r52570

comment:8 Changed 9 years ago by m-kiewitz

Keywords: script added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.