Opened 9 years ago

Closed 9 years ago

#5061 closed defect (fixed)

LSL1VGA Polish version crash

Reported by: SF/dam-soft Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 1

Description

There is a problem with polish version of LSL1SCI. Game is recognized as english version and when You try to start, ScummVM quits immediately.

Ticket imported from: #3037194. Ticket imported from: bugs/5061.

Change History (16)

comment:1 by SF/dam-soft, 9 years ago

Summary: LSL1VGA Polish versionLSL1VGA Polish version crash

comment:2 by m-kiewitz, 9 years ago

is this a fan translation?

Please run ScummVM from command-line and check if anything is written to console.

comment:3 by SF/dam-soft, 9 years ago

It's the official polish release of LSL1, it was released in the same compilation as AGI version of LSL1 (which is fully supported by ScummVM ;).

ScummVM runned from command-line shows:

User picked target 'lsl1sci-2' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10,
SCI11, SCI32]
Starting 'Sierra SCI Game'
The game in 'F:\ScummVM.daily2\LSL1VGA.pl\' seems to be unknown.
Please, report the following data to the ScummVM team along with name
of the game you tried to add and its version/language/etc.:
"resource.000", "b6097ff35cdc8469f02150fe2f824198", 4781210
"resource.map", "58330a85767e42a2487129913283ab5b", 3228

comment:4 by m-kiewitz, 9 years ago

please tell me what the contents of the VERSION file are. If it's possible - please also unpack the sierra interpreter and look inside what version is listed in there (search via hex-editor inside the file for "1."). If you are not that technical into computers nevermind.

comment:5 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz

comment:6 by SF/dam-soft, 9 years ago

VERSION: 2.1
in interpreter: 1.000.577

All the files of this version are exactly the same as they were in english release. Only difference is with RESOURCE.000 file and RESOURCE.MAP file. If it is necessary I can send You those RESOURCE files.

comment:7 by m-kiewitz, 9 years ago

Please try r51535. At least your version should get detected correctly.

Also please get SCI Viewer, open your directory and go to text resources -> now look inside 0.tex and there should be all sorts of lines, they should start with english sentences followed by polish sentences.

What I need to know is what the char after the # is right before the polish sentence starts. #P is already used for portuguese. In the worst case they also used #P.

comment:8 by SF/dam-soft, 9 years ago

Latest build detects game correctly, thanx. But there is still problem, ScummVM still quits immediately. Console shows:
User picked target 'lsl1sci-pl' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10,
SCI11, SCI32]
Starting 'Sierra SCI Game'

I've viewed first text file (in LSL1 files are named in 'old' style [text.000]) and it contains only polish sentences without any #.
I think the problem is with RESOURCE.000 file. As far I remember this file is actually build as "version 0" resource file and all files that polish version RESOURCE.000 contains are uncompressed (for example all sentences can be searched and viewed simply using hex viewer on RESOURCE.000).

comment:9 by m-kiewitz, 9 years ago

Please start ScummVM with command line parameters '-d4 --debugflags=RESMAN' and try again.

comment:10 by SF/dam-soft, 9 years ago

results:

Debuglevel (from command line): 4
Output sample rate: 22050 Hz
File::open: opening 'logo.bmp' failed
File::open: opening 'cursor.bmp' failed
File::open: opening 'cursor_small.bmp' failed
File::open: opening 'checkbox.bmp' failed
File::open: opening 'checkbox_empty.bmp' failed
File::open: opening 'radiobutton.bmp' failed
File::open: opening 'radiobutton_empty.bmp' failed
File::open: opening 'logo_small.bmp' failed
File::open: opening 'search.bmp' failed
User picked target 'lsl1sci-pl' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10,
SCI11, SCI32]
Starting 'Sierra SCI Game'
Starting detection in dir 'F:\ScummVM.daily\LSL1VGA.pl\'
+ resource.map
> 'resource.map': '58330a85767e42a2487129913283ab5b'
+ resource.000
> 'resource.000': 'b6097ff35cdc8469f02150fe2f824198'
MD5 Mismatch. Skipping (70010c20138541f89013bb5e1b30f16a) (58330a85767e42a248712
9913283ab5b)
Matched file: resource.map
Matched file: resource.000
Found game: lsl1sci (VGA Remake DOS/Polish) (126)
... new best match, removing all previous candidates
Running Leisure Suit Larry in the Land of the Lounge Lizards (VGA Remake/DOS/Polish)
resMan: Detected resource map version 1: SCI0 / Early SCI1
resMan: Detected volume version 1: SCI0 / Early SCI1
resMan: Detected Early SCI1
resMan: Detected VGA graphic resources

comment:11 by m-kiewitz, 9 years ago

Do you have an IRC client? Please go to irc.freenode.net channel #scummvm

If you don't maybe you have at least a compiler on your system. I could send you some temporary sourcecode for testing what is going wrong. My e-mail is m_kiewitz AT users DOT sourceforge DOT net

comment:12 by m-kiewitz, 9 years ago

fixed in r51577 (hopefully) please try it out and tell me, if everything works out correctly

comment:13 by m-kiewitz, 9 years ago

Resolution: fixed
Status: newpending

comment:14 by SF/dam-soft, 9 years ago

LSL1PL runs perfectly. Thanx. I try to play through it with a latest build in many different ways.

comment:15 by SF/dam-soft, 9 years ago

Status: pendingnew

comment:16 by SF/dam-soft, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.