Opened 9 years ago

Closed 9 years ago

#5037 closed defect (wontfix)

RTZ: Installed V1.2 MD5

Reported by: SF/optically Owned by: sev-
Priority: normal Component: Engine: MADE
Keywords: detection Cc:
Game: Return to Zork

Description

The 5000 bytes MD5 value for Return to Zork (V1.2, 9/29/94, installed, CD/DOS/English) -- i.e., that of the file "RTZCD.DAT" -- is currently the same as that of the V1.1 installed version, i.e., that of the V1.1 "RTZCD.DAT" file, yet undetected as such.

The issue is that both the V1.1 and the V1.2 files share the first 165125 bytes, hence a 5000 bytes md5 check cannot discriminate between those files. As a result, and because the selfsame 5000 bytes md5 is not. Something >165126 bytes, or just a fullsize one, would be necessary for the distinction. Both files are of the same size, 536064.

I do not know whether the forum-reported md5 that entered into detector.cpp is erroneous or not, but it is at the very least incomplete.

My md5 values are just as likewise reported on the forum by another poster, whose post is available here: http://forums.scummvm.org/viewtopic.php?p=45032#45032

// Return to Zork - English CD version 1.1 12/7/93
"rtzcd.red", "c4e2430e6b6c6ff1562a80fb4a9df24c", 276466 [56e5811fdcf83b056322664998a4401e]
// Return to Zork - English CD version 1.1 12/7/93 ( installed )
"rtzcd.dat", "a1db8c97a78dae10f91d356f16ad07b8", 536064 [f3fd89a6d6931f7fd27c6d65d1215157]
// Return to Zork - English CD version 1.2 9/29/94
"rtzcd.red", "946997d8b0aa6cb4e848bad02a1fc3d2", 276584 [31cd9197a352f58904fd8ea9ddc7924d]
// Return to Zork - English CD version 1.2 9/29/94 ( installed )
"rtzcd.dat", "a1db8c97a78dae10f91d356f16ad07b8", 536064 [f5c3c3740e9a20bbb26f7f952cf020bd]

Note the different fullsize md5 between the two installed version.

The V1.2 "RTZCD.DAT" is freely available as part of the V1.2 patch in a .rar, and one can readily verify its detection as V1.1. Here: http://dlh.net/cgi-bin/dlp.cgi?lang=eng&sys=pc&file=rtzcd12.zip&ref=ps

Tested on ScummVM 1.2.0svn51462.

Ticket imported from: #3036679. Ticket imported from: bugs/5037.

Change History (3)

comment:1 by SF/optically, 9 years ago

Priority: normallow

comment:2 by sev-, 9 years ago

Owner: set to sev-
Priority: lownormal
Resolution: wontfix
Status: newclosed

comment:3 by sev-, 9 years ago

Actually there is no real need to distinguish those because there is no difference from the engine point of view. I.e. if we would have some internal script fixes and those were mistakingly applied to incorrect version, then it would be necessary to detect the difference.

Currently it has no impact besides the detection string, but increasing number of MD5 bytes computed during the detection will slow down the overall detection especially on lower end devices.

Rejecting.

Note: See TracTickets for help on using tickets.