Opened 9 years ago

Closed 9 years ago

#5038 closed defect (fixed)

QFG1 VGA: Combat buttons work only sometimes

Reported by: SF/madsoesterby Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Quest for Glory 1

Description

ScummVM version: Win32 ScummVM Daily Snapshot (build from Subversion, 3882K Win32 exe file, last update: July 29, 2010, 12:22 pm)

Bug details, including instructions on reproducing:
(savegame is provided)
1. Start game as mage.
2. Go into forest.
3. Find a Saurus and engage in combat with it.
4. Observe that the combat buttons (cast zap, thrust, slash, etc) work only sometimes. I've tested both with mouse and with the numpad, the behavior seems to be exactly the same with both input methods.

The weird thing is that the problem seems to change depending on what monster you're fighting. A single goblin worked ok. Two goblins a little worse and against the Saurus it's very bad.

Language of game: English.

Version of game: VGA Remake/DOS/English.

Platform and Compiler: Win32. I've tested on two computers, both running Vista 32-bit.

Ticket imported from: #3036756. Ticket imported from: bugs/5038.

Attachments (1)

qfg1vga.000 (41.7 KB ) - added by SF/madsoesterby 9 years ago.
Savegame just before entering combat with a Saurus

Download all attachments as: .zip

Change History (12)

by SF/madsoesterby, 9 years ago

Attachment: qfg1vga.000 added

Savegame just before entering combat with a Saurus

comment:1 by SF/madsoesterby, 9 years ago

Component: Engine: SCI
Game: Quest for Glory 1

comment:2 by SF/madsoesterby, 9 years ago

By the way: Here's the stdout output:

-------------------------
User picked target 'qfg1vga' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10, SCI11, SCI32]
Starting 'Sierra SCI Game'
Emulating SCI version SCI1.1

WARNING: cmdDummy invoked!
WARNING: kDoSound(pause): Slot not found (0014:02bb)!
-------------------------

None of this seems related to the issue since they happen before the problem occurs.

Kind regards,
Mads Østerby

comment:3 by m-kiewitz, 9 years ago

this is actually the same as the pharkas "hotspot" issue (bug #3037192)

the scripts call kGetEvent twice. Once regulary and another one from within kAnimate -> warrior::doit -> closeCombat::doit -> pointBox::doit -> Event::new

comment:4 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz

comment:5 by m-kiewitz, 9 years ago

Keywords: original added
Resolution: fixed
Status: newclosed

comment:6 by m-kiewitz, 9 years ago

seems to also occur in original on dosbox with max cycles, but much more rarely. Anyway, i'm now patching the game runtime and removing this code - fixed in r52361

happy testing and fighting ;)

comment:7 by m-kiewitz, 9 years ago

Status: closednew

comment:8 by m-kiewitz, 9 years ago

the same issue occurs when fighting the weapon master. That script needs to get patched as well.

comment:9 by SF/kuroshiro, 9 years ago

Thanks for consolidating, and again it is not possible for people who are not members of the team to re-open bugs :)

comment:10 by m-kiewitz, 9 years ago

fixed the weapon master issue (same issue like the regular fighting) in r52381

@ kuroshiro: then plz just write me an e-mail next time. it's just bad when there are multiple duplicate reports.

comment:11 by m-kiewitz, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.