Opened 9 years ago

Closed 9 years ago

#4930 closed defect (fixed)

SWORD2: Mute setting does not work

Reported by: lordhoto Owned by: sev-
Priority: blocker Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

ScummVM trunk r51098
Linux/amd64 with g++ 4.4.4

The Broken Sword 2 engine does not support the "mute" setting at all. I tried to fix this by adopting Sword2Engine::syncSoundSettings, but that makes the sound settings in the menu of sword2 look wrong (i.e. all volumes are at 0, when one uses ScummVM's mute).

Patch for syncSoundSettings included.

Ticket imported from: #3032763. Ticket imported from: bugs/4930.

Attachments (1)

sword2_mute.patch (1.7 KB) - added by lordhoto 9 years ago.
Patch against r51098

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by lordhoto

Attachment: sword2_mute.patch added

Patch against r51098

comment:1 Changed 9 years ago by sev-

Component: Engine: Sword2
Game: Broken Sword 2
Owner: set to eriktorbjorn

comment:2 Changed 9 years ago by eriktorbjorn

I've made an attempt to fix this. Could you check if it seems to work well enough (or even at all)?

comment:3 Changed 9 years ago by sev-

Raising priority. This is a release-critical bug.

comment:4 Changed 9 years ago by sev-

Priority: normalblocker

comment:5 Changed 9 years ago by eriktorbjorn

As I said - over a month ago - I believe I've fixed this, but I would be grateful if someone else could try it and see if it works as intended.

comment:6 Changed 9 years ago by sev-

Owner: changed from eriktorbjorn to sev-
Resolution: fixed
Status: newclosed

comment:7 Changed 9 years ago by sev-

Fixed in SVN.

eriktorbjorn, your patch did not have any way of unmuting the sound.

Note: See TracTickets for help on using tickets.