Opened 9 years ago

Closed 9 years ago

Last modified 13 months ago

#4929 closed defect (fixed)

SCUMM: Mute setting does not work

Reported by: lordhoto Owned by: sev-
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

ScummVM trunk r51098
Linux/amd64 with g++ 4.4.4
Games tried: Monkey 2 and The Dig

The "mute" setting is not respected by SCUMM at all, neither when using it while the game is running via the GMM nor on startup.

I tried adopting ScummEngine::syncSoundSettings so that it behaves the same as Engine::syncSoundSettings when the "mute" config key is set to "true", but that only fixes digital iMuse it seems. At least then the mute option worked fine in The Dig, while not at all in Monkey 2 (tried with AdLib).

Ticket imported from: #3032758. Ticket imported from: bugs/4929.

Change History (12)

comment:1 by sev-, 9 years ago

Fixed in SVN.

comment:2 by sev-, 9 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:3 by lordhoto, 9 years ago

Reopening this bug report since Monkey 2 is still not fixed. Just start up Monkey 2 (with AdLib) and check the mute box in the GMM, the SFX in the copy protection won't be gone and you still have music in the intro. It seems all it does currently is to lower the sound volume, if you can't hear any music/sfx just turn up your speaker volume

comment:4 by lordhoto, 9 years ago

Resolution: fixed
Status: closednew

comment:5 by m-kiewitz, 9 years ago

noticed that as well in lsl5. When mute is enabled music is still playing but with a really low volume, although we correctly set the actual volume to be 0.

comment:6 by sev-, 9 years ago

Raising priority. This is a release-critical bug.

comment:7 by sev-, 9 years ago

Owner: sev- removed
Priority: normalblocker

comment:8 by lordhoto, 9 years ago

This is a general problem (or rather misunderstanding) of the OPL commands. It seems the OPL chips only feature a "very low" volume setting as 0, but no silence. So all engines which setup the OPL emulator as kPlainSoundType and only sending 0 as volume will still have (quite silent) output for OPL though.

comment:9 by sev-, 9 years ago

I am closing the bugreport then. Feel free to open another one (Adlib to respect volume 0), but it will be not release critical.

I just retested the game, at least with my speakers the sound is not heard with mute setting.

comment:10 by sev-, 9 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:11 by lordhoto, 9 years ago

Actually I tried my MT-32 now and it isn't fully muted there either, so I guess it's not an AdLib driver specific problem, but rather all our sound code assuming that a midi volume of 0 means no sound, which isn't really represented by 0 as it seems.

comment:12 by digitall, 13 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.