Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4765 closed defect (duplicate)

ITE: MidiParser::hangingNote(): Exceeded polyphony!

Reported by: sunmax Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

Playing ITE on ScummVM 1.0.0 on SDL backend:

leave the characters next to the tents out of the first scene
and -do not- touch anything for some time (i.e. don't play,
don't move the mouse just enjoy the music while doing
something else ;-)

After 30 mins to 1 hr, the music will stop playing and you will
see a lot of:

WARNING: MidiParser::hangingNote(): Exceeded polyphony!
WARNING: MidiParser::hangingNote(): Exceeded polyphony!
WARNING: MidiParser::hangingNote(): Exceeded polyphony!

scrolling in the terminal from which you launched ScummVM.

Moving the characters around will stop the flow of warnings,
but you will lose the beautiful music unless you restart :-(

A similar bug has been reported for Discworld:

DW: Noise after not playing a "few" hours - ID: 2797283

So we are probably looking at a more global ScummVM issue
(well, easy to reproduce if you just have to let the game run ;-)

Thanks!
-max

Ticket imported from: #2948281. Ticket imported from: bugs/4765.

Change History (6)

comment:1 by fingolfin, 10 years ago

Summary: MidiParser::hangingNote(): Exceeded polyphony!ITE: MidiParser::hangingNote(): Exceeded polyphony!

comment:2 by bluegr, 9 years ago

This issue has probably been fixed with r55256, can you please check if it still occurs?

comment:3 by bluegr, 9 years ago

Owner: changed from sev- to bluegr

comment:4 by bluegr, 9 years ago

Closing as duplicate of bug #2797283. This is a problem of the MIDI backend, not a problem in the game engine. For more information, please refer to that bug report

comment:5 by bluegr, 9 years ago

Resolution: duplicate
Status: newclosed

comment:6 by sunmax, 9 years ago

Tried on both vintage PII (350 Mhz) [SDL backend] and PS2 backend, and I cannot reproduce it anymore after 12 hours, so I can confirm it's fixed ;-)

Note: See TracTickets for help on using tickets.