Opened 11 years ago

Closed 11 years ago

#4764 closed defect (fixed)

LOL: Crash in Cimmeria

Reported by: SF/ifo Owned by: athrxx
Priority: normal Component: Engine: Kyra
Version: Keywords:
Cc: Game: Kyrandia 1

Description

I've just discovered another segmentation fault, this time in Cimmeria. To reproduce the crash load the attached savegame and turn to your right. This should reproducibly kill ScummVM.

ScummVM: 1.1.0svn48010 (Feb 8 2010 22:56:19) Game: Lands of Lore German CD version (part of "10 Jahre Westwood" compilation) Platform: Linux (Slackware64 13.0), gcc 4.3.3

Ticket imported from: #2948109. Ticket imported from: bugs/4764.

Attachments (1)

lol-cd.021 (28.7 KB ) - added by SF/ifo 11 years ago.
Savegame

Download all attachments as: .zip

Change History (5)

by SF/ifo, 11 years ago

Attachment: lol-cd.021 added

Savegame

comment:1 by athrxx, 11 years ago

Owner: set to athrxx

comment:2 by athrxx, 11 years ago

This seems to be a problem with that special door to the right (script bug) which would cause invalid memory access. I have added a fix for that. Please try whether this works for you.

Florian

comment:3 by SF/ifo, 11 years ago

Resolution: fixed
Status: newclosed

comment:4 by SF/ifo, 11 years ago

Thanks, this change fixed the crash!

Note: See TracTickets for help on using tickets.