Opened 17 years ago

Closed 16 years ago

Last modified 16 years ago

#463 closed defect (wontfix)

LOOM: Ending scene contains logo

Reported by: SF/dfabulich Owned by: eriktorbjorn
Priority: low Component: Engine: SCUMM
Keywords: script Cc:
Game: Loom

Description

After you cast the final spell (C f g c) and fly off,
the log reports a switch to room 2. This was the
"starry night" view that appeared at the opening of the
game with the LucasArts logo.

Unfortunately, it still has the logo as the room loads
up. The logo then disappears as the swans fly past.
(This did not occur in the original version; I just
tested it.)

[After the swans fly past, the logo reappears for the
final credits; this is as designed.]

ScummVM 0.2.2 CVS
Built on Sep 15 2002 22:58:14

(downloaded Win32 snapshot)

Ticket imported from: #609724. Ticket imported from: bugs/463.

Attachments (2)

loomcd.s04 (41.1 KB) - added by SF/dfabulich 17 years ago.
Saved game right before ending
loomcd.2.s04 (42.1 KB) - added by SF/dfabulich 17 years ago.
Current saved game

Download all attachments as: .zip

Change History (24)

comment:1 Changed 17 years ago by SF/ender

Hi Dan,
Can you please attach a save-game near this point of your game?
If it's before the Chaos scene, make sure you also include your threads (The
spell threads, except for two of them, are randomly generated per-game) .

Thanks.
- Ender
ScummVM Project Leader

(JOOC, are you the CM Dan? :)

comment:2 Changed 17 years ago by SF/ender

Owner: set to SF/ender
Priority: normallow

comment:3 Changed 17 years ago by eriktorbjorn

There's a savegame just before chaos arrives attached to bug
report #605970. Perhaps that could be used?

Changed 17 years ago by SF/dfabulich

Attachment: loomcd.s04 added

Saved game right before ending

comment:4 Changed 17 years ago by SF/dfabulich

I just attached a saved game that you should be able to use.
Just cast (C f g c) to see the problem. Of course, this is
a little tricky due to bug #609723... So perhaps try these
note numbers instead, ordered from left to right: 8th 4th
5th 1st.

PS: How many 'dfabulich's could there possibly *be* in the
world, ender? ;) And, BTW, ah, cool project you've got
going here. ;)

comment:5 Changed 17 years ago by SF/andrej4000

This problem is vanished now!
I played the game with the CVS from 7th November today.

This report can be closed I think.

comment:6 Changed 17 years ago by SF/ender

Yep, seems gone to me.

LEC didn't go very good spellchecking back then, did they? "I am
Choas" indeed.

comment:7 Changed 17 years ago by SF/ender

Resolution: worksforme
Status: newclosed

comment:8 Changed 17 years ago by SF/dfabulich

This bug should be re-opened. It still happens, but it only
happens if you hit ESC while the LEC logo is on the screen
as the game opens. I've attached a saved game from tonight
that demonstrates the bug; this is from today's snapshot.

Changed 17 years ago by SF/dfabulich

Attachment: loomcd.2.s04 added

Current saved game

comment:9 Changed 17 years ago by SF/ender

Status: closednew

comment:10 Changed 17 years ago by SF/ender

Ah, I see.

Reopening per Dan's request.

comment:11 Changed 17 years ago by fingolfin

We could possible hack around this by cleaning out the logo
when the room is left?!?

I wonder how this did work in the original. Are we doing
something wrong, or did this bug exist in the original, too,
or did they simply have a hack for this?

comment:12 Changed 16 years ago by fingolfin

Seriously, can somebody verify this is not present in the real game, too? It might be a script bug (not cleaning up properly when the cutscene is aborted).

comment:13 Changed 16 years ago by fingolfin

Owner: changed from SF/ender to eriktorbjorn

comment:14 Changed 16 years ago by fingolfin

Still happens, but to be really sure it's still there in current CVS, one
would have to start a new game from scratch, I'd think.

Would be useful if we had a cheat mode to just make all drafts / notes
"known" to bobbing, then debugging this would be much eaier - just
teleport to room 66, use the cheat to get all drafts/notes, then cast
spell and verify problem is fixed or not.

Since erik implemented the "drafts" debugger command already, I
assign this to him in the hope that he maybe can make such a cheat :-)

comment:15 Changed 16 years ago by fingolfin

Using erik's new cheat debug command I managed to veify that it
really still exists with the very latest CVS ;-)

Anyway, the quest remains open: does this occur in the original, too,
or does it work properly? Note: to test, one has to do the same in the
original, i.e. skip the intro while the logo is visible. As long as we don't
know this, I personally won't bother to investigate closer (but
everybody else feel free to if you have the time :-)

comment:16 Changed 16 years ago by SF/udvarnoky

The logo does NOT appear at ALL at the end.

comment:17 Changed 16 years ago by fingolfin

udvarnoky, your comment is very fuzzy (and hence not very
helpful). What do you mean: in the original it is not supposed to
appear? We already know that. Or do you want to say that the bug
is fixed in latest CVS? I am very surprised to hear that. Did you
actually exactly and careful follow the instructions on how to
reproduce it? Because otherwise it won't appear indeed.

comment:18 Changed 16 years ago by SF/udvarnoky

Please totally ignore my message. I meant to say that it is
NOT SUPPOSED to show up at all in the end. In any case,
please disregard.

comment:19 Changed 16 years ago by SF/dfabulich

Yup, this bug appears in the original. I just played
through LoomCD/Talkie. When the logo came up, I hit ESC.
Then I plowed through the rest of the game. When the game
finally ended, the logo was there and then quickly
disappears. I'm using "Interpreter Verson 5.1.42 CD-ROM"
(at least, that's what it says when I type "loom.exe --help").

comment:20 Changed 16 years ago by fingolfin

Thanks a lot dfabulich, very helpful.

Now we just have to decide: do we close this as wontfix, or do we
try to hack in a workaround to fix this glitch? Should be possible,
question is, do we want to do it?

comment:21 Changed 16 years ago by SF/ender

It's completely cosmetic, and very minor... so in my
opinion it's not worth adding a hack for.

Closing :)

comment:22 Changed 16 years ago by SF/ender

Resolution: worksformewontfix
Status: newclosed
Note: See TracTickets for help on using tickets.