Opened 11 years ago

Closed 11 years ago

Last modified 12 months ago

#4171 closed defect (invalid)

TINSEL: ‘ADGF_NO_FLAGS’ is not a member of ‘Common’

Reported by: SF/abevi Owned by: lordhoto
Priority: normal Component: Engine: Tinsel
Keywords: build Cc:
Game:

Description

The following error is thrown on compilation from the source checked out from subversion (latest head version is 38389):

engines/tinsel/detection.cpp:334: error: ‘ADGF_NO_FLAGS’ is not a member of ‘Common’

Steps to reproduce:

make distclean
./configure --enable-tinsel
make

Ubuntu Desktop 8.04 (x86)
gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu12)

Ticket imported from: #2607413. Ticket imported from: bugs/4171.

Change History (6)

comment:1 by lordhoto, 11 years ago

I find that one rather strange for me line 334 of that file is:
ADGF_NO_FLAGS
thus it does not try to access Common:: here, could you please check what your line looks like?

comment:2 by SF/abevi, 11 years ago

Lines 323->340:

{ // US Discworld 2 release
{
"dw2",
"CD",
{
{"dw2.scn", 0, "c6d15ce9720a9d8fef06e6582dcf3f34", 103593},
{"english1.smp", 0, "cf8ceaee28e53850792e35fc86263bb5", 105358318},
{NULL, 0, NULL, 0}
},
Common::EN_ANY,
Common::kPlatformPC,
Common::ADGF_NO_FLAGS
},
GID_DW2,
0,
GF_CD | GF_SCNFILES,
TINSEL_V2,
},

comment:3 by SF/abevi, 11 years ago

Please ignore this. I removed detection.cpp and did an svn up and the line no longer shows ADGF_NO_FLAGS being associated with the Common namespace ...... weird.

comment:4 by lordhoto, 11 years ago

Ok... :-)

comment:5 by lordhoto, 11 years ago

Owner: set to lordhoto
Resolution: invalid
Status: newclosed

comment:6 by digitall, 12 months ago

Component: Engine: Tinsel
Note: See TracTickets for help on using tickets.