Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#4170 closed defect (worksforme)

SWORD2: No free slot in FX queue

Reported by: wjp Owned by: wjp
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

After playing through BS2 from the beginning up to the British Museum (without leaving scummvm or reloading), talking to the Japanese girls there froze the game with a stream of "WARNING: No free slot in FX queue!" messages.

Couldn't reproduce this after reloading from a savegame.

This is with Gentoo on amd64, English talkie BS2, DXA video, scummvm 0.13 branch from 2009-02-16.

Ticket imported from: #2607089. Ticket imported from: bugs/4170.

Change History (7)

comment:1 by eriktorbjorn, 11 years ago

The FX queue is an array with information about sound effects that will be played later. They can be of the type "spot" (play once), "random" (played at random intervals) or "looped". I believe spot effects are generally set up when an animation starts and the game knows there should be a sound effect X frames later. Random effects are probably used for background bird noises, etc.

It should only contain information about sounds in the current room (it is cleared when entering a new room), so if you want to try and reproduce it, you should be able to do so without re-playing the game from the beginning. There can be 32 elements in the queue, so it's strange that it should ever fill up. Though there doesn't seem to be anything to stop the same effect from being added multiple times.

(I believe it's also cleared when restoring a game, which would explain why you couldn't reproduce it with your savegame.)

comment:2 by wjp, 11 years ago

I tried a couple of times from the previous scene (Ketch's Landing), but couldn't reproduce it anymore.

comment:3 by sev-, 10 years ago

Should we close this bugreport then?

comment:4 by wjp, 10 years ago

I've tried to reproduce it a dozen times again with current SVN, but it never occurred again, so let's close it.

comment:5 by wjp, 10 years ago

Resolution: worksforme
Status: newclosed

comment:6 by Kirben, 10 years ago

Owner: set to wjp

comment:7 by wjp, 9 years ago

Follow-up: tdhs and eriktorbjorn tracked this down and fixed it at bug #2976008.

Note: See TracTickets for help on using tickets.