Opened 12 years ago

Closed 12 years ago

#3914 closed defect (fixed)

MM: Charset out of bounds!

Reported by: raziel- Owned by: eriktorbjorn
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

ScummVM 0.13.0svn (Aug 22 2008 22:32:46) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

I get a (45:1:0x29E): charset -1 is out of bounds (0,8)! when starting MM Amiga, irght before the top text with copyright should appear. Console comes up and i can only quit

Unfortunately this also affects the 0.12.0 release!!!

Maniac Mansion (V2/Amiga/English)

AmigaOS4 gcc version 4.0.2 (AmigaOS build 20051012)

Works fine in 0.11.1

Ticket imported from: #2081347. Ticket imported from: bugs/3914.

Change History (8)

comment:1 by Kirben, 12 years ago

Actually this problem is specific to ScummVM 0.13.0svn and was caused by revision 33552 by sev.

comment:2 by Kirben, 12 years ago

Owner: set to sev-

comment:3 by lordhoto, 12 years ago

I get the very same error with MM DOS v2 German (from the DOTT CD version) on my Linux/amd64 with r34521.

comment:4 by Kirben, 12 years ago

Priority: normalblocker

comment:5 by Kirben, 12 years ago

This problem actually effects all V0/V1/V2 versions of Maniac Mansion and Zak McKracken.

comment:6 by eriktorbjorn, 12 years ago

I didn't realize others had already looked at this. Maybe CharsetRendererV3 should set _curId to 0, to preserve the old behaviour for older games. Or maybe that's just a hack. I don't really understand the implications of the change that caused the regression yet.

comment:7 by eriktorbjorn, 12 years ago

Owner: changed from sev- to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:8 by eriktorbjorn, 12 years ago

After thinking some more about it, I guess it's v2 and earlier games that should initialise _curId to 0. After all, they only have one single hard-coded font, don't they? I've applied that fix, so I'm closing the bug. I'm sure someone will re-open it if I'm wrong.

Note: See TracTickets for help on using tickets.