Opened 12 years ago

Closed 12 years ago

Last modified 2 years ago

#3913 closed defect (fixed)

DW: Pushing ESC repeatedly at beginning causes odd behavior

Reported by: SF/clemty Owned by: fingolfin
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

0.13.0 self-compiled SVN on XP Discworld 1 (German version; speech + subs German, not switchable)

Hitting "Escape" repeatedly as soon as the game starts skips the intro and puts Rincewind on the overhead map immediately. Enter the townsquare and trunk is following him. Enter the university and his room, trunk is still sleeping in Rincewind's room.

While I don't have much experience with DW1 this behavior looks unintentional.

Savegame attached.

Ticket imported from: #2078922. Ticket imported from: bugs/3913.

Attachments (1)

dw-de.001 (1.3 KB ) - added by SF/clemty 12 years ago.
savegame

Download all attachments as: .zip

Change History (4)

by SF/clemty, 12 years ago

Attachment: dw-de.001 added

savegame

comment:1 by fingolfin, 12 years ago

Fixed.

The problem is that normally you *can't* skip the first few intro screens at all. During debugging Tinsel, we added a hack to allow to skip it with ESC anyway, to be able to get quickly to the "load" menu. That hack does not work completely right in the german version, though. Hence I disabled it now.

comment:2 by fingolfin, 12 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:3 by digitall, 2 years ago

Component: Engine: Tinsel
Game: Discworld
Note: See TracTickets for help on using tickets.