Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#3915 closed defect (duplicate)

MONKEY: Can't load a save of the final scene

Reported by: SF/whiteclone Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 1

Description

If I save on the final scene of the game ("Turn off your computer and go to bed!"), trying to load it results in the following error:

Room 0: data not found (engines/scumm/room.cpp:258)!

Steps to reproduce:
1. Complete Secret of Monkey Island, and save on the last scene (after the credits [though I didn't check if this also happens in the credits scene])
2. Load the new save file

scummvm -v:
ScummVM 0.11.1 (Aug 27 2008 23:18:18)
Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2

Language: English
Version: Full PC CD version
Platform: Linux / GCC 4.1.2

Attached is a copy of a save I made which triggers the error.

Note that I have NOT confirmed this bug with the latest SVN build.

Ticket imported from: #2085677. Ticket imported from: bugs/3915.

Attachments (1)

monkey.s02 (9.3 KB ) - added by SF/whiteclone 11 years ago.
Save which triggers error

Download all attachments as: .zip

Change History (6)

by SF/whiteclone, 11 years ago

Attachment: monkey.s02 added

Save which triggers error

comment:1 by fingolfin, 11 years ago

The real bug is that it lets you save there, I think. I.e. it is no surprise that a save made there does not work...

comment:2 by fingolfin, 11 years ago

Priority: normallow

comment:3 by fingolfin, 11 years ago

This artifact has been marked as a duplicate of artifact 1745396 with reason:
Duplicate

comment:4 by fingolfin, 11 years ago

Status: newclosed

comment:5 by Kirben, 10 years ago

Owner: set to fingolfin
Resolution: duplicate
Note: See TracTickets for help on using tickets.